Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234300 - smbfs slab corruption
Summary: smbfs slab corruption
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jeff Layton
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-28 11:20 UTC by Vasily Averin
Modified: 2008-01-09 17:29 UTC (History)
3 users (show)

Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-15 16:24:01 UTC


Attachments (Terms of Use)
this patch is missed hunk in linux-2.6.9-smbfs-uid-gid.patch, sets the default files and dir permission (deleted)
2007-03-28 11:20 UTC, Vasily Averin
no flags Details | Diff
patch from mainstream, fixes smbfs slab corruption (deleted)
2007-03-28 11:23 UTC, Vasily Averin
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0791 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 4 Update 6 2007-11-14 18:25:55 UTC

Description Vasily Averin 2007-03-28 11:20:26 UTC
There is known issue that "mount -t smbfs" without dmask and fmask slleps on the
30 sec and produced the following messages:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=168280
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=202934

I've investigated the reasons of these messages and found that on the
RHEL4-based kernel with SLAB_DEBUG enabled this test shows the slab corruption:

init_special_inode: bogus i_mode (0)
smb_retry: no connection process
smb_add_request: request [000001000bd22d38, mid=1802201963] timed out!
smb_delete_inode: could not close inode 2
Slab corruption: start=000001000bd22d38, len=344
Redzone: 0x5a2cf071/0x5a2cf071.
Last user: [<ffffffffa00ba56d>](smb_add_request+0x42d/0x4d0 [smbfs])
010: 6a 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b
150: 02 00 58 00 fb ff ff ff
Prev obj: start=000001000bd22bc8, len=344
Redzone: 0x5a2cf071/0x5a2cf071.
Last user: [<0000000000000000>](0x0)
000: 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b
010: 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b

Comment 1 Vasily Averin 2007-03-28 11:20:27 UTC
Created attachment 151106 [details]
this patch is missed hunk in linux-2.6.9-smbfs-uid-gid.patch, sets the default files and dir permission

Comment 3 Vasily Averin 2007-03-28 11:29:51 UTC
It was reproduced on the 2.6.9-42.0.10.EL kernel

Comment 4 Jeff Layton 2007-05-11 15:14:02 UTC
Thanks for the patches and for doing the legwork to track down a reproducer!

I've attached the patch in comment #1 to BZ 168280 and will plan to propose it
for that BZ. I've also confirmed that the patch in comment #2 fixes the slab
corruption, so I'll plan propose that one to fix this BZ.


Comment 6 RHEL Product and Program Management 2007-05-11 20:41:43 UTC
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.

Comment 7 Jason Baron 2007-06-22 14:29:53 UTC
committed in stream U6 build 55.11. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/


Comment 10 errata-xmlrpc 2007-11-15 16:24:01 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html



Note You need to log in before you can comment on or make changes to this bug.