Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234218 - gdm defaults to gnome.desktop even if gnome isn't installed.
Summary: gdm defaults to gnome.desktop even if gnome isn't installed.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-03-27 18:40 UTC by Dan
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-12 20:53:37 UTC


Attachments (Terms of Use)
anaconda-ks.cfg generated by F7 test3 installer (deleted)
2007-03-30 11:55 UTC, Dan
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 403690 None None None Never

Description Dan 2007-03-27 18:40:13 UTC
Description of problem:
During fresh installation of Fedora 7 test2, Gnome unselected and KDE selected
still installs Gnome and makes it the default gdm instead of KDE.

Version-Release number of selected component (if applicable):


How reproducible:
Occurred on both FC6 and F7test2.

Steps to Reproduce:
1.  Deselect Gnome and select KDE during installation customization
2.
3.
  
Actual results:
Gnome and KDE installed, Gnome default gdm.

Expected results:
Only KDE installed and default gdm.

Additional info:
P4 1.8Ghz, 256mb RAM, 40gb WesterDigital hard drive, Nvidia 5600XT

Comment 1 Jeremy Katz 2007-03-28 19:18:46 UTC
Can you provide the /root/anaconda-ks.cfg?  And does this still happen with test3?

Comment 2 Dan 2007-03-30 11:55:16 UTC
Created attachment 151266 [details]
anaconda-ks.cfg generated by F7 test3 installer

Comment 3 Jeremy Katz 2007-04-02 17:07:41 UTC
We'll default to gdm in all cases.  But gdm should be doing the right thing
without the gnome bits installed.

Comment 4 Ray Strode [halfline] 2007-04-02 18:31:11 UTC
What do you mean by "right thing" ?

Comment 5 Jeremy Katz 2007-04-02 18:38:17 UTC
We shouldn't be trying to start a gnome session if gnome isn't installed.

Comment 6 Ray Strode [halfline] 2007-04-02 19:24:00 UTC
ah, retitling.

This is probably fallout from the "Xclients entry"-ectomy that Matthias did a
while back.

Adding to FC7Target.

Comment 7 Matthew Miller 2007-04-10 15:55:48 UTC
Bulk message: Fedora 7 test bugs should be filed against "devel", not against
test1/2/3. This isn't obvious, I know. Moving this report so it isn't lost.

Comment 8 Matthias Clasen 2007-04-10 22:55:51 UTC
Looks like we need to reinstate default.desktop. That'll make /etc/gdm/Xsession
fall thru to running /etc/X11/xinit/Xclients, which will detect if gnome or kde
are installed and run whichever it finds.

Comment 9 Ray Strode [halfline] 2007-04-11 16:43:09 UTC
yea, but we should probably call it legacy.desktop or xclients.desktop and make
sure that GDM will pick *something* as a default if the configured default
doesn't exist.

Comment 10 Matthias Clasen 2007-04-11 18:00:16 UTC
If you look at how /etc/X11/xinit/Xclients handles this, it will run gnome or kde,
as long as one of them is installed, falling back to the other if the preferred
desktop is not installed. 

I don't mind keeping the name default.desktop. It is after all, the default
that we ship in /usr/share/gdm/defaults.conf

Of course, all the layers and fallbacks in /etc/gdm/Xsession
and/etc/X11/xinit/Xclients are a bit grotty...


Comment 11 Ray Strode [halfline] 2007-04-11 18:11:12 UTC
So, what I want to do is ship defaults.desktop (or whatever we call it in
xorg-x11-xinit , we already ship gnome.desktop in gnome-session I believe, so
then  there is the matter of the default... It should probably be gnome.desktop
and if gnome.desktop doesn't exist it should just pick something.

Be it Xclients or kde.desktop or whatever

Comment 12 Matthias Clasen 2007-04-11 18:21:19 UTC
No. Look at the handling in Xclients. We can just make default.desktop the
default, then things work (and gnome will be preferred if it is installed).

Comment 13 Matthias Clasen 2007-04-11 18:22:54 UTC
The whole point of default.desktop is that you can make it the default, and 
Xclients does the heavy lifting to figure out what is installed and what is
preferred, and what should be run. The final fallback being xsm, without a check
that it exists. Ugh.

Comment 14 Ray Strode [halfline] 2007-04-11 18:53:08 UTC
I don't want to route through Xclients going forward though.  I'm pretty sure
we've talked about this before.

For Fedora 7 we should probably just make things work again, granted.

Comment 15 Ray Strode [halfline] 2007-04-11 19:15:13 UTC
the related upstream bug is here: 

http://bugzilla.gnome.org/show_bug.cgi?id=403690

btw

Comment 16 Matthias Clasen 2007-04-12 19:49:01 UTC
Oh, now I see that I removed the default.desktop file because of the stupid name. 
Just calling it "Default" again would be a bit better, I guess.

I think the point of routing through Xclients is that you can share the "pick a
desktop" logic between gdm and startx, but it may not be worth it.

We really need to remove all remnants of xsm support though.

Comment 17 Ray Strode [halfline] 2007-04-12 20:41:08 UTC
Yea, I'll just add it back as a builtin session called Default for Fedora 7.  We
can fix it better for fedora 8

Comment 18 Ray Strode [halfline] 2007-04-12 20:53:37 UTC
okay 2.16 default.desktop is in place now.  We can do a better fix for Fedora 8.


Note You need to log in before you can comment on or make changes to this bug.