Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234216 - You can't actually buy albums using the Magnatune plugin
Summary: You can't actually buy albums using the Magnatune plugin
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-27 18:31 UTC by David Nielsen
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 0.9.8-4.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-28 15:56:38 UTC


Attachments (Terms of Use)

Description David Nielsen 2007-03-27 18:31:27 UTC
Description of problem:
You can't actually buy albums using the Magnatune plugin, it simply sits there
after you click buy, the cancel button also doesn't seem to have any effect.

The following can be seen in a terminal.

Traceback (most recent call last):
  File "/usr/lib64/rhythmbox/plugins/magnatune/__init__.py", line 82, in <lambda>
    action.connect('activate', lambda a:
self.shell.get_property("selected-source").purchase_album())
  File "/usr/lib64/rhythmbox/plugins/magnatune/MagnatuneSource.py", line 199, in
purchase_album
    gladexml.get_widget("info_label").set_text(_("Would you like to purchase the
album '%(album)s' by '%(artist)s'.") % (album, artist))
TypeError: format requires a mapping

Version-Release number of selected component (if applicable):
rhythmbox-0.9.8-2.fc7

How reproducible:
100%

Steps to Reproduce:
1. Enable Magnatune plugin
2. Select album and click the "Buy Album" button
3. Enter requested information and click the "Buy" confirmation button
  
Actual results:
Nothing happens

Expected results:
I'd love for there to be the exchange of money for music, that would be really
helpful to my general enjoyment of life.

Additional info:

Comment 1 Bastien Nocera 2007-03-27 22:47:38 UTC
Looks like:
http://bugzilla.gnome.org/show_bug.cgi?id=412931

Would you mind trying to apply this patch to
/usr/lib64/rhythmbox/plugins/magnatune/MagnatuneSource.py and letting me know
whether it works?
http://svn.gnome.org/viewcvs/rhythmbox/branches/RHYTHMBOX-0_10/plugins/magnatune/magnatune/MagnatuneSource.py?r1=4849&r2=4876&view=patch

Comment 2 David Nielsen 2007-03-27 23:12:02 UTC
The patch from SVN works however Rhythmbox crashed after authenticating with the
Magnatude server - I wasn't running with debug symbols installed so what I
captured wasn't useful. However I got my confirmation mail so the order went
through and the crash might not have been related.

I can't really afford to keep retesting though.

Comment 3 Bastien Nocera 2007-03-28 00:14:02 UTC
So you got charged twice? If so, I'll do it myself and put it on expenses :)

I'll apply the patch in the next rawhide build, thanks.

Comment 4 David Nielsen 2007-03-28 00:30:28 UTC
No I got charged once but the crash occured after buying and them charging my
card.. so to attempt to reproduce it I'd have to keep buying music. Not the most
unpleasant experience in the world really but I could go broke doing that with
my track record.

Comment 5 Bastien Nocera 2007-03-28 15:56:38 UTC
Fixed in rhythmbox-0.9.8-4.fc7 for rawhide, and rhythmbox-0.9.8-2.fc6 for FC6.


Note You need to log in before you can comment on or make changes to this bug.