Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234182 - system-config-users pops two warning dialogs about a weak password
Summary: system-config-users pops two warning dialogs about a weak password
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-users
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-27 16:19 UTC by petrosyan
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: system-config-users-1.2.54-1.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-30 07:46:51 UTC


Attachments (Terms of Use)

Description petrosyan 2007-03-27 16:19:56 UTC
Description of problem:
When creating a new user using system-config-users and choosing a weak password
for the user system-config-users pops a warning dialog that says: "The chosen
password is too weak: it is based on a dictionary word. Do you want to use it
anyway?" after choosing "Yes" it asks the same exact question again.


Version-Release number of selected component (if applicable):
system-config-users-1.2.53-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. create a new user using system-config-users
2. choose a weak password for the user
3. after being warned about the weak password click "Yes"
  
Actual results:
It asks the same question again.

Expected results:
The warning should be shown only once.

Comment 1 petrosyan 2007-03-28 22:01:15 UTC
this bug is still present in system-config-users-1.2.54-1.fc7

Comment 2 petrosyan 2007-03-28 22:07:41 UTC
this bug actually has been fixed in system-config-users-1.2.54-1.fc7

Comment 3 petrosyan 2007-03-28 22:09:59 UTC
I was wrong again. This bug actually is present in system-config-users-1.2.54-1.fc7

Comment 4 Nils Philippsen 2007-03-29 07:12:44 UTC
I know, I know ... ;-).
I plan to look into this shortly.

Comment 5 Nils Philippsen 2007-03-30 07:46:51 UTC
Version 1.2.55 is building right now which should fix this issue. Please test it
once it hits the mirrors, if the test fails, please reopen.

Comment 6 Nils Philippsen 2007-03-30 07:52:04 UTC
Make that version 1.2.56...


Note You need to log in before you can comment on or make changes to this bug.