Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234170 - udev doesn't create block device for major 68 minor 0 as it forces the name to /dev/capi20
Summary: udev doesn't create block device for major 68 minor 0 as it forces the name t...
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: udev
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-27 15:36 UTC by Simone Gotti
Modified: 2007-11-17 01:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-05 22:27:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Simone Gotti 2007-03-27 15:36:04 UTC
Description of problem:

I cannot find a similar issue on bugzilla. Perhaps it's related to bug #167291.
Sorry if it's duplicated.

On a system with RHEL4-U4 and a lot of scsi devices the block device /dev/sdbm
that has major 68 and minor 0 isn't created (noticed because multipath -l
reports only 3 paths instead of 4). Looking at /etc/udev/rules.d/50-udev.rules
this major is forced to be called capi20:

SYSFS{dev}="68:0",              NAME="capi20"

[root@itradedb03c ~]# udevinfo -q all -p /block/sdbm
P: /block/sdbm
N: capi20
T: b
M: 060660
S:
O: root
G: uucp
F: /etc/udev/rules.d/50-udev.rules
L: 67
U: 2834
R: 0

Removing this line fixed it.

Version-Release number of selected component (if applicable):

udev-039-10.15.EL4

How reproducible:

The system was just installed didn't rebooted. But I think it'll always happen.
  
Actual results:

/dev/sdbm (the block device that has major 68 and minor 0 isn't created because
overrided by /dev/capi20) 

Expected results:

/dev/sdbm created.

Comment 2 RHEL Product and Program Management 2007-05-18 16:25:20 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Andrius Benokraitis 2007-06-05 22:27:22 UTC
Simone, it looks like IBM has already found this issue and is working to resolve
this for RHEL 4.6.

*** This bug has been marked as a duplicate of 202792 ***


Note You need to log in before you can comment on or make changes to this bug.