Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234144 - iwlwifi messages: long/short preample handling
Summary: iwlwifi messages: long/short preample handling
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-27 14:09 UTC by Tom London
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-17 18:03:40 UTC


Attachments (Terms of Use)

Description Tom London 2007-03-27 14:09:37 UTC
Description of problem:
Get lots of the following messages when wifi is 'turned on' (ipw3945 on thinkpad
X60):

Mar 27 06:57:24 localhost kernel: iwlwifi: XXXY start rate scale
Mar 27 06:57:32 localhost NetworkManager: <info>  wlan0: Device is
fully-supported using driver 'iwlwifi'. 
Mar 27 06:57:32 localhost kernel: iwlwifi: TODO: Look into long/short preamble
change handling.
Mar 27 06:57:32 localhost kernel: iwlwifi: TODO: Look into long/short preamble
change handling.
Mar 27 06:57:32 localhost kernel: iwlwifi: TODO: Look into long/short preamble
change handling.


Version-Release number of selected component (if applicable):
kernel-PAE-2.6.20-1.3023.fc7

How reproducible:
every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tom London 2007-04-02 02:02:47 UTC
This problem continues wit .3038.

Any useful info I can provide?

Comment 2 Dave Jones 2007-04-04 05:05:58 UTC
yes, this one is particularly easy to trigger it seems.
John, shall we just disable that particular IPW_WARNING for now?


Comment 3 Bryan O'Sullivan 2007-04-12 06:55:55 UTC
FWIW, in at least some cases, the warning seems to be strongly correlated with
actual problems, for example association flapping with WEP (see bug 235247).

Comment 4 John W. Linville 2007-04-12 13:14:51 UTC
FWIW, iwlwifi had IPW_WARNING set to use KERN_ERR (which IPW_ERROR uses) 
instead of KERN_WARNING.  I put a patch in rawhide (kernel 3057) to correct 
that apparent typo.  Does this quiet things down a bit?

Comment 5 Tom London 2007-04-12 13:40:05 UTC
I downloaded/installed .3059 this morning.

No change, noisy as ever.  Same frequent error messages.  

Here are some falling right in the middle of WEP authentication dance....

Apr 12 06:34:13  localhost wpa_supplicant[3577]: Trying to associate with
00:12:17:46:42:51 (SSID='free4all' freq=2457 MHz) 
Apr 12 06:34:13  localhost wpa_supplicant[3577]: Association request to the
driver failed 
Apr 12 06:34:13  localhost kernel: hwcrypto disabled!
Apr 12 06:34:13  localhost kernel: iwlwifi: TODO: Look into long/short preamble
change handling.
Apr 12 06:34:13  localhost kernel: iwlwifi: Network RSSI: -39
Apr 12 06:34:13  localhost kernel: iwlwifi: REPLY_ADD_STA failed
Apr 12 06:34:13  localhost kernel: iwlwifi: Network RSSI: -39
Apr 12 06:34:13  localhost kernel: iwlwifi: REPLY_ADD_STA failed
Apr 12 06:34:13  localhost kernel: iwlwifi: Network RSSI: -40
Apr 12 06:34:15  localhost NetworkManager: <info>  Old device 'eth0' activating,
won't change. 
Apr 12 06:34:28  localhost wpa_supplicant[3577]: Authentication with
00:00:00:00:00:00 timed out. 
Apr 12 06:34:28  localhost kernel: iwlwifi: TODO: Look into long/short preamble
change handling.


Comment 6 John W. Linville 2007-04-25 18:47:54 UTC
Tom, I think the "iwlwifi: REPLY_ADD_STA failed" messages should be handled in 
bug 235247.

Comment 7 John W. Linville 2007-05-17 18:03:40 UTC
The "long/short preamble" message is no longer in the sources...


Note You need to log in before you can comment on or make changes to this bug.