Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234132 - MIssing monitor related code in merge_into()
Summary: MIssing monitor related code in merge_into()
Keywords:
Status: CLOSED DUPLICATE of bug 234131
Alias: None
Product: Fedora
Classification: Fedora
Component: rhpxl
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-27 10:17 UTC by Vasile Chelban
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-27 10:23:32 UTC


Attachments (Terms of Use)
xhwstate.py patch (deleted)
2007-03-27 10:17 UTC, Vasile Chelban
no flags Details | Diff

Description Vasile Chelban 2007-03-27 10:17:20 UTC
Description of problem:
system-config-display does not change monitor type if another monitor section 
is already present in xorg.conf.

Version-Release number of selected component (if applicable):
rhpxl-0.39-2 (FC6), rhpxl-0.43-1.fc7 (F7T2)


How reproducible:
by changing any of monitor related options like vrefresh, hsync, or monitor name

Steps to Reproduce:
1. Set inittial monitor section (assume that no monitor is already configured): 
system-config-display --set-hsync=31.5-86.0 --set-vsync=60-160 
2. try to change any of monitor options: system-config-display -o /tmp/
xorg.conf --set-hsync=31.5-60.0
3. see the difference: diff -u /etc/xorg.conf /tmp/xorg.conf|grep HorizSync
  
Actual results:
no differences found, i.e. second step failed

Expected results:
-        HorizSync    31.5 - 86.0
+        HorizSync    31.5 - 60.0


Additional info:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=176592 - seems to be 
duplicate
Actual bug is missing monitor related code in merge_into() routine from 
xhwstate.py (rhpxl package). See the attached patch that fixed issue for me.

Comment 1 Vasile Chelban 2007-03-27 10:17:20 UTC
Created attachment 151006 [details]
xhwstate.py patch

Comment 2 Vasile Chelban 2007-03-27 10:23:32 UTC

*** This bug has been marked as a duplicate of 234131 ***


Note You need to log in before you can comment on or make changes to this bug.