Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234128 - compiz can't be rebuilded without --disable-kde
Summary: compiz can't be rebuilded without --disable-kde
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
: 227803 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-27 09:19 UTC by Mykola Ulianytskyi
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-27 19:23:49 UTC


Attachments (Terms of Use)

Description Mykola Ulianytskyi 2007-03-27 09:19:39 UTC
Description of problem:
compiz can't be rebuilded without --disable-kde because
KDE_WINDOW_DECORATOR_CFLAGS doesn't include "-I/usr/include/kde/" by default.

Version-Release number of selected component (if applicable):
compiz-0.3.6-2

How reproducible:
rpmbuild -ba compiz.spec

Additional info:
Add --disable-kde to %configure to fix possible future build errors.

Comment 1 Kristian Høgsberg 2007-03-27 19:23:49 UTC
Thanks, fixed in 0.3.6-4.fc7.


Comment 2 Kevin Kofler 2007-03-29 00:24:00 UTC
Can't the actual problem, i.e. "KDE_WINDOW_DECORATOR_CFLAGS doesn't 
include "-I/usr/include/kde/" by default", be fixed instead? Please don't 
forget that KDE is in Fedora too.

Comment 3 Kristian Høgsberg 2007-03-29 00:43:49 UTC
I would build the KDE window decorator if possible, but the problem is that it
requires the old Qt d-bus bindings, which we don't ship.


Comment 4 Joachim Frieben 2007-03-29 07:47:27 UTC
This bug was a clone of bug 227803.

Comment 5 Kristian Høgsberg 2007-03-29 16:12:18 UTC
*** Bug 227803 has been marked as a duplicate of this bug. ***

Comment 6 drago01 2007-03-29 17:15:28 UTC
(In reply to comment #3)
> I would build the KDE window decorator if possible, but the problem is that it
> requires the old Qt d-bus bindings, which we don't ship.
> 

they are in extras so when the merge happens it should build fine.


Note You need to log in before you can comment on or make changes to this bug.