Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234118 - Different characters are used in rm <file> command in interactive mode.
Summary: Different characters are used in rm <file> command in interactive mode.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: coreutils
Version: 4.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Ondrej Vasik
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-27 06:28 UTC by Subramanyam
Modified: 2007-12-06 13:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-12-06 13:50:44 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Subramanyam 2007-03-27 06:28:16 UTC
Description of problem:
Different characters are used in rm <file> command.

Version-Release number of selected component (if applicable):

Red Hat Enterprise Linux AS release 4 (Nahant Update 4)
Linux hostname 2.6.9-42.ELsmp #1 SMP Wed Jul 12 23:27:17 EDT 2006 i686 i686 i386
GNU/Linux

How reproducible:


Steps to Reproduce:
1. create a tempfile
2. run the command rm <filename>
3. Type y to delete the file
  
Actual results:
rm: remove regular empty file `tempFile'? y


Expected results:
rm: remove regular empty file `tempFile`? y
or
rm: remove regular empty file 'tempFile'? y


Additional info:
In the interactive mode the file name in encoded in two different characters "`"
and "'", so any one character should be used as `filename` or 'filename'.
Preferably 'filename'

Comment 1 Phil Knirsch 2007-03-27 08:12:07 UTC
This is related to the rm command, which in turn is part of package coreutils.

Reassigning bug to proper component.

Read ya, Phil

Comment 2 Ondrej Vasik 2007-12-06 13:50:44 UTC
Sorry for late response. That is not a bug, that is expected behavior. This is
one of the correct quoting styles generally used by coreutils (to check all
correct coreutils quoting styles you could read
http://www.gnu.org/software/coreutils/manual/html_node/Formatting-the-file-names.html#Formatting-the-file-names).

Anyway - changing behavior - like default quoting style for some command - is
dangerous thing in distribution like RHEL, because that style could be expected
in some scripts/parsers - and  change like this will break them. Closing NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.