Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234106 - atapi tape drive no longer writeable
Summary: atapi tape drive no longer writeable
Keywords:
Status: CLOSED DUPLICATE of bug 150335
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-27 01:16 UTC by Kelly-Rand
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-09 19:35:35 UTC


Attachments (Terms of Use)
Output from dmesg for the kernel that write access works. (deleted)
2007-03-30 23:46 UTC, Kelly-Rand
no flags Details
Output from dmesg for the kernel that write access does not work (deleted)
2007-03-30 23:48 UTC, Kelly-Rand
no flags Details

Description Kelly-Rand 2007-03-27 01:16:39 UTC
Description of problem:The new libata subsystem does not allow me to write to my
atapi tape drive.


Version-Release number of selected component (if applicable):Fc6 kernel
2.6.20-1.2925

How reproducible: Constant


Steps to Reproduce:
mt -f /dev/nst0 erase # as root
causes this output:
Mar 24 21:15:29 bagend kernel: st0: Current: sense key: Illegal Request
Mar 24 21:15:29 bagend kernel:     Additional sense: Invalid command operation code

1.
2.
3.
  
Actual results:
See above

Expected results:
Tape marks to be overwritten so tape can be overwritten from beginning. Also,
the backup script fails with the same output. 


Additional info:
Saturday morning I booted into my old Fc5 partition and ran by backup script
that uses the ide-tape module. It was successful and I could read the data by
issuing "tar -jtf /dev/nht0".
I then booted into Fc6 running the latest kernel 2.6.20-1.2933. There the device
nst0 is now automatically created and linked to tape and tape_nst0. Using the mt
command I can rewind, retension, fsf (1-N), and check status with no problem. I
can also read the data on the tape with the above tar command.
I can not erase or write to the tape with the scuzzy driver.
When I forward space the tape it will move to the next file mark but when I
check the status it does not know where it is by block per this output:

# mt -f /dev/nst0 status
SCSI 2 tape drive:
File number=2, block number=0, partition=0.
Tape block size 512 bytes. Density code 0x45 (QIC-3095-MC (TR-4)).
Soft error count since last status=0
General status bits on (81010000):
 EOF ONLINE IM_REP_EN

When I try to write to the tape I get this error:

# less /var/log/messages | grep -i st0
# Below are the error messages when I try to write to the tape
Mar 24 21:15:29 bagend kernel: st0: Current: sense key:
Illegal Request
Mar 24 21:15:29 bagend kernel: Additional sense: Invalid
command operation code

Do I need to tell the st driver explicitly the tape block size? Do I use the mt
command to do that or is there another means? Or am I just the victim of scsi's
past inability to access tape drives on the same cable as another device as in a
cd / dvd ?

Is there a way to get more error output from the drive?

Jim K-R

Comment 1 Chuck Ebbert 2007-03-30 22:02:57 UTC
Can you post /var/log/dmesg from bootup of a working kernel and a non-working one?


Comment 2 Kelly-Rand 2007-03-30 23:46:55 UTC
Created attachment 151337 [details]
Output from dmesg for the kernel that write access works.

Comment 3 Kelly-Rand 2007-03-30 23:48:26 UTC
Created attachment 151338 [details]
Output from dmesg for the kernel that write access does not work

Comment 4 Kelly-Rand 2007-04-07 17:31:10 UTC
I think this bug is now the same as bug 150335.
I will no longer post information here unless it is requested. I have posted a
substantial amount of follow-up data under bug 150335.

Comment 5 Chuck Ebbert 2007-04-09 19:35:35 UTC
I don't even have mt installed here. What package is it in?


*** This bug has been marked as a duplicate of 150335 ***


Note You need to log in before you can comment on or make changes to this bug.