Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234051 - rpmlint catches strange permissions only when the rpm is already installed
Summary: rpmlint catches strange permissions only when the rpm is already installed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rpmlint
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-26 19:48 UTC by Till Maas
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-26 20:57:43 UTC


Attachments (Terms of Use)

Description Till Maas 2007-03-26 19:48:38 UTC
rpmlint complained about /usr/share/doc/<package>/doc having strange permissions
(set guid), but only when the package is already installed. rpm -v -qpl
<package> shows the strange permissions already without the package beeing
installed, so rpmlint could also check for the permissions in the  rpm, without
it beeing installed.

I wanted to report this here, but trac complained about a missing form cookie,
but it seems it never event wanted to give me a cookie. Maybe you can forward this.
http://rpmlint.zarb.org/cgi-bin/trac.cgi/newticket

Comment 1 Ville Skyttä 2007-03-26 20:20:41 UTC
Hmm, trac submission worked fine for me as anonymous.
http://rpmlint.zarb.org/cgi-bin/trac.cgi/ticket/57

Do you have a package around which can be used to test this?  I could not
reproduce in some quick tests.

Comment 2 Till Maas 2007-03-26 20:33:35 UTC
(In reply to comment #1)

> Hmm, trac submission worked fine for me as anonymous.
> http://rpmlint.zarb.org/cgi-bin/trac.cgi/ticket/57

I tried to use my name instead if anonymous, maybe this was the problem.
 
> Do you have a package around which can be used to test this?  I could not
> reproduce in some quick tests.

http://www-users.kawo2.rwth-aachen.de/~tmaas/fedora/repo/whysynth-dssi-20060122-7.i386.rpm



Comment 3 Ville Skyttä 2007-03-26 20:46:26 UTC
I think you need to register and login if you wish to use something else than
anonymous.

Anyway, I cannot reproduce with the test package either:

$ rpm -q rpmlint
rpmlint-0.79-1.fc6.noarch

$ rpm -V rpmlint
(no output)

$ rpm -q whysynth-dssi
package whysynth-dssi is not installed

$ rpmlint whysynth-dssi-20060122-7.i386.rpm
E: whysynth-dssi non-standard-dir-perm /usr/share/doc/whysynth-dssi-20060122/doc
02755
W: whysynth-dssi dangling-relative-symlink /usr/bin/whysynth jack-dssi-host


Comment 4 Till Maas 2007-03-26 20:57:43 UTC
(In reply to comment #3)
> $ rpmlint whysynth-dssi-20060122-7.i386.rpm
> E: whysynth-dssi non-standard-dir-perm /usr/share/doc/whysynth-dssi-20060122/doc
> 02755
> W: whysynth-dssi dangling-relative-symlink /usr/bin/whysynth jack-dssi-host

Ok, the problem was, that I installed a rpm, that was made with rpmbuild and has
the strange permission, but I ran rpmlint on a mock built, which does not have
the strange permissions problem. 




Note You need to log in before you can comment on or make changes to this bug.