Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234026 - yum installs incorrect arch version of kernel kernel-devel packages (i686 vs i586)
Summary: yum installs incorrect arch version of kernel kernel-devel packages (i686 vs ...
Keywords:
Status: CLOSED DUPLICATE of bug 211941
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-26 17:58 UTC by Máirín Duffy
Modified: 2014-01-21 22:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-25 19:27:58 UTC


Attachments (Terms of Use)

Description Máirín Duffy 2007-03-26 17:58:58 UTC
Description of problem:

i have an intel ibm thinkpad t41 running fc6. i upgraded my kernel using yum
upgrade kernel, rebooted into it, and did yum install kernel-devel on it. look
at the results:

[duffy@yuna 2.6.20-1.2933.fc6]$ rpm -q kernel kernel-devel
--qf="%{n}-%{v}-%{r}.%{arch}\n"
kernel-2.6.19-1.2911.6.5.fc6.i586
kernel-2.6.20-1.2933.fc6.i586
kernel-devel-2.6.20-1.2933.fc6.i686

The 2.6.19-1.2911.6.5.fc6.i586 kernel I believe was installed when I first
installed this system; i did not install it myself as far as I can remember and
I do not see it in /var/log/yum.log.

Version-Release number of selected component (if applicable):
yum-3.0-6

Comment 1 Will Woods 2007-03-26 18:18:45 UTC
There's a known bug in the FC6 installer where it will install the i586 kernel
instead of (or in addition to) the i686 one - see bug #211941.

http://fedoraproject.org/wiki/Bugs/FC6Common has more info and a fix.

Does that solve your problem?

Comment 2 Jeremy Katz 2007-04-25 19:27:58 UTC

*** This bug has been marked as a duplicate of 211941 ***


Note You need to log in before you can comment on or make changes to this bug.