Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234006 - system-config-kickstart dies on startup
Summary: system-config-kickstart dies on startup
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-kickstart
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-26 16:22 UTC by Zack Cerza
Modified: 2014-01-21 22:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-25 17:49:18 UTC


Attachments (Terms of Use)
traceback; /var/tmp/yum-test-RtsSod/ is empty. (deleted)
2007-03-26 16:22 UTC, Zack Cerza
no flags Details
system-config-kickstart debug output (deleted)
2007-04-20 21:54 UTC, Christopher Brown
no flags Details

Description Zack Cerza 2007-03-26 16:22:18 UTC
Description of problem:
s-c-kickstart crashes on startup with a traceback if started via the menu. It
appears to start up successfully if launched from a terminal.

Version-Release number of selected component (if applicable):
system-config-kickstart-2.7.4-1.fc7

How reproducible:
Always

Comment 1 Zack Cerza 2007-03-26 16:22:18 UTC
Created attachment 150910 [details]
traceback; /var/tmp/yum-test-RtsSod/ is empty.

Comment 2 Zack Cerza 2007-03-26 16:27:47 UTC
Comment on attachment 150910 [details]
traceback; /var/tmp/yum-test-RtsSod/ is empty.

sigh, it's a freaking text file, bugzilla :P

Comment 3 Zack Cerza 2007-03-26 16:33:39 UTC
Oh, heh, actually the failure is causes by being non-root.

Comment 4 Chris Lumens 2007-03-27 18:38:44 UTC
I'm seeing this with repoquery as well.

Comment 5 Christopher Brown 2007-04-20 21:54:30 UTC
Created attachment 153219 [details]
system-config-kickstart debug output

Comment 6 Christopher Brown 2007-04-20 21:55:09 UTC
Also seeing this. See attached debug output.

Comment 7 Chris Lumens 2007-04-23 14:37:23 UTC
Christopher - that is a different bug than the one originally addressed in this
report, and is tracked by bug 236999.

Comment 8 Jeremy Katz 2007-04-24 22:01:02 UTC
This is fixed with CVS yum, at least the main part.  

I then get a different traceback since you've enabled the core repo which ends
up with a releasever of 6.92 and there isn't a valid mirrorlist for that. 
You're either going to need to 
  1) catch the RepoError in doRepoSetup()
  2) or individually setup the repos when you enable them (repo.setup())

Comment 9 Chris Lumens 2007-04-25 17:49:18 UTC
We weren't able to reproduce this on today's rawhide, so I'm closing this out.


Note You need to log in before you can comment on or make changes to this bug.