Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234005 - Can't mount external USB drive with NTFS permission due to SELinux policy
Summary: Can't mount external USB drive with NTFS permission due to SELinux policy
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 6
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-26 16:22 UTC by Robin Bowes
Modified: 2008-01-30 19:16 UTC (History)
0 users

Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-30 19:16:00 UTC


Attachments (Terms of Use)

Description Robin Bowes 2007-03-26 16:22:13 UTC
Description of problem:

I am unable to mount an external USB drive with an NTFS partition because of an
SELinux policy restriction. The error msg is:

SELinux is preventing /usr/bin/fusermount (mount_t) "mount" to / (unlabeled_t)

Version-Release number of selected component (if applicable):
fuse-2.6.3-2.fc6
filesystem-2.4.0-1

How reproducible:
Fails every time

Steps to Reproduce:
1.Plugin USB drive to USB port
2.Fedora attempts to mount to /media/Tosh01
  
Actual results:
It fails with the above error

Expected results:
USB to be mounted as /media/Tosh01

Additional info:
This works fine with SELinux turned off (setenforce 0)

Comment 1 Daniel Walsh 2007-04-03 13:03:21 UTC
Fixed in selinux-policy-2.4.6-49

Comment 2 Robin Bowes 2007-05-04 09:06:35 UTC
This is now working, but I still see this AVC denial:

SElinux is preventing /sbin/mount.ntfs-3g (mount_ntfs_t) "use" to /dev/null
(hald_t).

Comment 3 Daniel Walsh 2007-05-04 14:38:51 UTC
Fixed in selinux-policy-2.4.6-69

Comment 4 Daniel Walsh 2007-08-22 14:12:50 UTC
Fixed in current release

Comment 5 Robin Bowes 2007-08-23 00:30:50 UTC
This is still a problem on FC6:

SELinux is preventing /sbin/mount.ntfs-3g (mount_ntfs_t) "search" to media (mnt_t)

and:

SELinux is preventing /sbin/mount.ntfs-3g (mount_ntfs_t) "write" to pipe:[60020]
(hald_t).

R.

Comment 6 Daniel Walsh 2007-09-13 17:26:23 UTC
Fixed in 	selinux-policy-2.4.6-88.fc6


Note You need to log in before you can comment on or make changes to this bug.