Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233982 - Latest ConsoleKit requires 18 new unnecessary packages
Summary: Latest ConsoleKit requires 18 new unnecessary packages
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ConsoleKit
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-26 14:15 UTC by Jarkko
Modified: 2013-03-06 03:49 UTC (History)
1 user (show)

Fixed In Version: 0.2.1-0.git20070402
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-02 21:16:10 UTC


Attachments (Terms of Use)

Description Jarkko 2007-03-26 14:15:41 UTC
Description of problem: Latest ConsoleKit in the development repository adds
requirements for all kinds of X related packages. Non-graphical server
environments don't need these packages.

Version-Release number of selected component (if applicable): 0.2.0-2.fc7

How reproducible: Always

Steps to Reproduce:
1. Use Rawhide with ConsoleKit < 0.2.0-2.fc7
2. Run "yum upgrade"
3. See the suggested package list
  
Actual results:

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 ConsoleKit              x86_64     0.2.0-2.fc7      development        67 k
 ConsoleKit-libs         x86_64     0.2.0-2.fc7      development        13 k
Installing for dependencies:
 atk                     x86_64     1.18.0-1.fc7     development       233 k
 cairo                   x86_64     1.4.2-1.fc7      development       431 k
 cups-libs               x86_64     1:1.2.10-1.fc7   development       179 k
 fontconfig              x86_64     2.4.2-2.fc7      development       178 k
 freetype                x86_64     2.3.2-1.fc7      development       320 k
 gnutls                  x86_64     1.4.5-1          development       363 k
 gtk2                    x86_64     2.10.11-1.fc7    development       6.7 M
 hicolor-icon-theme      noarch     0.10-2           development        32 k
 libXcursor              x86_64     1.1.8-1          development        32 k
 libXfixes               x86_64     4.0.3-1          development        15 k
 libXft                  x86_64     2.1.12-1.fc7     development        44 k
 libXi                   x86_64     1.0.2-1          development        29 k
 libXinerama             x86_64     1.0.1-2.1        development        10 k
 libjpeg                 x86_64     6b-37            development       140 k
 libpng                  x86_64     2:1.2.16-1.fc7   development       237 k
 libthai                 x86_64     0.1.7-5.fc7      development       153 k
 libtiff                 x86_64     3.8.2-7.fc7      development       318 k
 pango                   x86_64     1.16.1-1.fc7     development       356 k

Transaction Summary
=============================================================================
Install     18 Package(s)
Update       2 Package(s)
Remove       0 Package(s)

Total download size: 9.8 M
Is this ok [y/N]: n

Expected results:

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 ConsoleKit              x86_64     0.2.0-2.fc7      development        67 k
 ConsoleKit-libs         x86_64     0.2.0-2.fc7      development        13 k

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       2 Package(s)
Remove       0 Package(s)

Total download size: 80 k
Is this ok [y/N]: y

Additional info: I *really* hope those new dependencies were added accidentally.
I don't want to install X related packages to this system. :)

Comment 1 jmccann 2007-03-26 18:45:28 UTC
In git I've changed the tool to use xlib directly to open the display.  That
should go a long way.  I suppose we could try to dlopen libX11...

Comment 2 David Zeuthen 2007-03-26 19:20:18 UTC
Matthias suggests to move the tool into a sub package, say, ConsoleKit-x11 and
just make gdm and, in the future, xorg-x11-xinit, pull that in. Thoughts?

Comment 3 Jarkko 2007-03-27 05:59:49 UTC
This is what hal does (pulls ConsoleKit in). I have ConsoleKit installed in this
server system because I use smartmontools which requires hal which in turn
requires ConsoleKit.

We don't want to have a system where everything requires everything. :)

So, ConsoleKit-x11 sounds like a good idea.

Comment 4 David Zeuthen 2007-04-02 21:16:10 UTC
Fixed in ConsoleKit-0.2.1-0.git20070402.


Note You need to log in before you can comment on or make changes to this bug.