Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233961 - Package Request: NetworkManager-pptp
Summary: Package Request: NetworkManager-pptp
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact:
URL:
Whiteboard:
: 244556 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-26 11:22 UTC by Soren Mathiasen
Modified: 2008-12-02 04:15 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-12-02 04:15:06 UTC


Attachments (Terms of Use)

Description Soren Mathiasen 2007-03-26 11:22:32 UTC
Please include PPTP VPN support in the NetworkManager, the module should be
included in the latest version in SVN

Comment 1 Frank Schmitt 2007-04-18 12:47:06 UTC
I'd really appreciate this, too.

Comment 2 fullo 2007-05-09 09:56:48 UTC
Mee too!

Comment 3 Matt Martz 2007-06-01 18:28:26 UTC
There is a pptp option for knetworkmanager why not for the Gnome Networkmanager.

I would really appreciate this package as well.

Comment 4 Christopher Aillon 2007-06-01 18:31:57 UTC
Um, it's there but it's not in the main RPM.

yum install knetworkmanager-pptp

Comment 5 Christopher Aillon 2007-06-01 18:38:58 UTC
Oh, i see what you're saying.  You want the gnome client.

It hasn't been packaged yet, but it's not something that will be part of the NM
package itself.  And I personally don't use so it's not something I'd work on. 
But anyone is free to create a package and submit it to Fedora.

http://fedoraproject.org/wiki/PackageMaintainers/NewPackageProcess

Comment 6 Christopher Aillon 2007-06-18 17:23:23 UTC
*** Bug 244556 has been marked as a duplicate of this bug. ***

Comment 7 Christopher Aillon 2007-06-18 17:33:06 UTC
Re-opening and assigning to nobody.  If someone wants to pick this up, they are
more than welcome to do so.

Comment 8 Lubomir Kundrak 2007-11-15 21:14:54 UTC
Hi! I made an initial attempt to package the thing:

Spec file: http://people.redhat.com/lkundrak/SPECS/NetworkManager-ppp_vpn.spec
SRPM:
http://people.redhat.com/lkundrak/mock-results/NetworkManager-ppp_vpn-0.7.0-1.svn3085.fc8.i386/NetworkManager-ppp_vpn-0.7.0-1.svn3085.fc8.src.rpm
Mock results:
http://people.redhat.com/lkundrak/mock-results/NetworkManager-ppp_vpn-0.7.0-1.svn3085.fc8.i386/

If you have a short look at the NetworkManager-ppp_vpn-0.7.0-hacks.patch you'll
notice that THE PACKAGE IS NOT YET FUNCTIONAL, I just added it so that it
builds. I did not test any functionality and I suspect that at least resolver
and routes won't set up correctly.

I'd be very glad if anyone picked this up and fixed the outstanding issues, or
maybe just asked upstream for some small help. I'm probably not the right person
to do that, maybe I'll try to fix that unless someone else does. Thanks!

Comment 9 Anders G 2008-04-11 13:15:22 UTC
I would appreciate this very much too. Many users connecting to work from home
need this.

A colleague of mine uses Ubuntu, and this works from Ubuntu with
networkmanager-pptp. A package is provided and istallable via APT. Hopefully
there is a solution for Fedora as well that could be used from F9.

BR
Anders

Comment 10 Lubomir Kundrak 2008-04-11 14:09:42 UTC
http://people.redhat.com/lkundrak/SRPMS/NetworkManager-ppp_vpn-0.7.0-0.3.svn3549.fc8.src.rpm

Won't build.
Anyone, please pick it and fix :)

Comment 11 Michael Monreal 2008-04-19 11:28:18 UTC
This is one of the most outstanding bugs that keeps me to come back to Fedora
(the 9.0 release looks to be awesome!) from Ubuntu. Sadly my university network
also requires pptp.

Lubomir: what's the issue? is the pptp plugin not yet ported to NM 0.7? I have
not looked at this closely myself but on Ubuntu (still on NM 0.6.x) this "just
worked" in the last few releases.

Comment 12 Lubomir Kundrak 2008-04-19 13:32:39 UTC
Last time I checked it was the "not ported yet" thing.

Comment 13 Michael Monreal 2008-04-19 15:02:42 UTC
(In reply to comment #12)
> Last time I checked it was the "not ported yet" thing.

This is too bad :(
I have checked SVN and it looks like the pptp plugin is not really maintained
upstream. Did so much change from 0.6.5 -> 0.7 that it is nontrivial to port?

Comment 14 Michael Monreal 2008-04-19 15:31:58 UTC
I have tried to make some sense of the OpenVPN->0.7 port (svn diff --revision
2951:2952) but it really seems to be quite a bit :(
To make things worse, there are many whitespace changes as well, making the diff
harder to understand. 

Comment 15 Bug Zapper 2008-05-14 02:42:12 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 16 Gen Zhang 2008-08-02 11:10:46 UTC
As indicated by the upstream devs:
http://blogs.gnome.org/dcbw/2008/07/20/the-road-to-networkmanager-07/ the
current svn head now has a compatible pptp plugin. Can we get this into the
fedora tree?

Comment 17 Patrick 2008-08-14 14:13:15 UTC
As can be read here at the link below, Dan Williams has ported this plugin to the 0.7 API so I would *really* appreciate it if this plugin were shipped. Preferably as soon as possible :)

http://blogs.gnome.org/dcbw/2008/07/20/the-road-to-networkmanager-07/

I tried to just build the stuff and didn't get anywhere so I'm afraid I can't be much help.

To Lubomir Kundrak: the links in your comments #8 and #10 are redirected to v3.sk/~lkundra and end up 404. Mind fixing those links so that the files are available?

Comment 18 Arthur Pemberton 2008-08-20 07:22:29 UTC
Found this bug report via Google. I am in need of a pptp plugin for NetworkManager since everything is about NetworkManager in F9. pptpconfig gets the job done. But I am interested in this.

Is there anything that I can do to assist with this? Does the spec file work/not work?

Comment 19 Patrick 2008-08-20 10:21:41 UTC
Arthur, thank you for offering to help out! Which spec file? Afaict there is no spec file available. The links to the SRPMs in comment #8 en #10 are dead so not very helpful. I tried to build the pptp part of NetworkManager from svn trunk but got many errors (mostly header file related) which I don't know how to fix. I did just find an old SRPM that might be useful although it's based on the obsolete 0.6.x version:
http://download.fedora.redhat.com/pub/epel/5/SRPMS/NetworkManager-pptp-0.6.4-2.el5.src.rpm

Comment 20 Hedayat Vatankhah 2008-09-14 05:46:14 UTC
I've tried NetworkManager-pptp from the testing repository and it works! :)
(except some difficulties: http://bugzilla.gnome.org/show_bug.cgi?id=552190)

Comment 21 Bill Nottingham 2008-12-02 04:15:06 UTC
This exists now.


Note You need to log in before you can comment on or make changes to this bug.