Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233955 - Bad file descriptor: apr_socket_accept
Summary: Bad file descriptor: apr_socket_accept
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: httpd
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-26 11:14 UTC by Jóhann B. Guðmundsson
Modified: 2009-09-02 11:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-02 11:49:53 UTC


Attachments (Terms of Use)
strace -f apachectl graceful >& strace-httpd.txt (deleted)
2007-03-26 11:14 UTC, Jóhann B. Guðmundsson
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1380 normal SHIPPED_LIVE httpd bug fix update 2009-09-01 11:48:49 UTC

Description Jóhann B. Guðmundsson 2007-03-26 11:14:04 UTC
Description of problem:

[Mon Mar 26 11:05:14 2007] [error] (9)Bad file descriptor: apr_socket_accept:
(client socket)

Version-Release number of selected component (if applicable):

httpd-2.2.3-6.el5

How reproducible:

Happens everytime I run apachectl graceful

Steps to Reproduce:
1. apachectl graceful
2. and again apachectl graceful etc. etc.
3.
  
Actual results:

Bad file descriptor: apr_socket_accept: (client socket)

Expected results:

No error

Additional info:

Comment 1 Jóhann B. Guðmundsson 2007-03-26 11:14:05 UTC
Created attachment 150890 [details]
strace -f apachectl graceful >& strace-httpd.txt

Comment 2 Joe Orton 2007-04-26 09:19:59 UTC
Thanks for the report.  This is actually a harmless error; it occurs because the
socket on which the server calls accept() is immediately closed in child
processes, upon receipt of the graceful restart signal.

It may be possible to safely hide it from the logs or avoid it somehow, however.

Comment 3 David K. Means 2007-12-02 00:06:31 UTC
According to a Debian website, this problem has been isolated and fixed in
release 2.2.6-2 from the Apache team.  All that would be required of the Fedora
project is to repackage the stuff into an FC7 (and FC8) RPM.  Who is the right
person to take this on?


Comment 4 Jóhann B. Guðmundsson 2008-07-16 13:43:39 UTC
1. This was filled against RHEL 
2. did httpd get patched with this fix 
3. Since this is harmless and just an noise it can be closed as FIXED

Comment 5 Joe Orton 2009-03-19 15:44:49 UTC
There was a set of changes related to graceful restart handling proposed by a Debian developer, but I don't think it will have made a difference for the single-listener case as is covered here.

It does look like it's possible to avoid logging this in the graceful restart case.

Comment 9 Miroslav Vadkerti 2009-07-09 14:09:18 UTC
created RHTS test /CoreOS/httpd/misc/bug233955

Comment 11 errata-xmlrpc 2009-09-02 11:49:53 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1380.html


Note You need to log in before you can comment on or make changes to this bug.