Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233945 - java-1.5.0-gcj-1.5.0.0-7.fc7 at installation seems to miss prefix, ant fails to work afterwards
Summary: java-1.5.0-gcj-1.5.0.0-7.fc7 at installation seems to miss prefix, ant fails ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.5.0-gcj
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Fitzsimmons
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-26 08:45 UTC by Caolan McNamara
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 1.5.0.0-9.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-26 17:27:57 UTC


Attachments (Terms of Use)

Description Caolan McNamara 2007-03-26 08:45:23 UTC
Description of problem:
i.e. rpm install gives...

[root@Jehannum rpms]# rpm --upgrade java-1.5.0-gcj-*
/usr/bin/rebuild-gcj-db: line 6: /bin/gcj-dbtool: No such file or directory
dirname: missing operand
Try `dirname --help' for more information.
mkdir: missing operand
Try `mkdir --help' for more information.
/usr/bin/rebuild-gcj-db: line 13: /bin/gcj-dbtool: No such file or directory
xargs: /bin/gcj-dbtool: No such file or directory
/usr/bin/rebuild-gcj-db: line 6: /bin/gcj-dbtool: No such file or directory
/usr/bin/rebuild-gcj-db: line 6: /bin/gcj-dbtool: No such file or directory
dirname: missing operand
Try `dirname --help' for more information.
mkdir: missing operand
Try `mkdir --help' for more information.
/usr/bin/rebuild-gcj-db: line 13: /bin/gcj-dbtool: No such file or directory
xargs: /bin/gcj-dbtool: No such file or directory
/usr/bin/rebuild-gcj-db: line 6: /bin/gcj-dbtool: No such file or directory



Version-Release number of selected component (if applicable):
java-1.5.0-gcj-1.5.0.0-7.fc7


How reproducible:
always

Steps to Reproduce:
1. install above version
2. run ant

e.g. 

/usr/src/redhat/BUILD/OOF680_m10/rhino/unxlngi6.pro/misc/build/rhino1_5R4/build.xml:53:
The following error occurred while executing this line:
/usr/src/redhat/BUILD/OOF680_m10/rhino/unxlngi6.pro/misc/build/rhino1_5R4/src/build.xml:18:
Unable to find a javac compiler;
com.sun.tools.javac.Main is not on the classpath.
Perhaps JAVA_HOME does not point to the JDK

3.
  
Additional info:
this version is not in rawhide yet, but is in brew so affects building packages
that use ant

Comment 1 Caolan McNamara 2007-03-26 08:54:05 UTC
hmm

ls -l /usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/lib/tools.jar

/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/lib/tools.jar ->
../../../../share/java/libgcj-tools-4.1.2.jar

and that is provided by libgcj-src-4.1.2-5.i386.rpm so for my ant problem at
least it looks like that java-1.5.0-gcj-1.5.0.0-7.fc7 should simply require
libgcj-src

Comment 2 Thomas Fitzsimmons 2007-03-26 15:02:56 UTC
(In reply to comment #1)

> and that is provided by libgcj-src-4.1.2-5.i386.rpm so for my ant problem at
> least it looks like that java-1.5.0-gcj-1.5.0.0-7.fc7 should simply require
> libgcj-src

Fixed in Rawhide, 1.5.0.0-8.fc7.

(In reply to comment #0)
> Description of problem:
> i.e. rpm install gives...
> 
> [root@Jehannum rpms]# rpm --upgrade java-1.5.0-gcj-*
> /usr/bin/rebuild-gcj-db: line 6: /bin/gcj-dbtool: No such file or directory
> dirname: missing operand
> Try `dirname --help' for more information.
> mkdir: missing operand
> Try `mkdir --help' for more information.
> /usr/bin/rebuild-gcj-db: line 13: /bin/gcj-dbtool: No such file or directory
> xargs: /bin/gcj-dbtool: No such file or directory
> /usr/bin/rebuild-gcj-db: line 6: /bin/gcj-dbtool: No such file or directory
> /usr/bin/rebuild-gcj-db: line 6: /bin/gcj-dbtool: No such file or directory
> dirname: missing operand
> Try `dirname --help' for more information.
> mkdir: missing operand
> Try `mkdir --help' for more information.
> /usr/bin/rebuild-gcj-db: line 13: /bin/gcj-dbtool: No such file or directory
> xargs: /bin/gcj-dbtool: No such file or directory
> /usr/bin/rebuild-gcj-db: line 6: /bin/gcj-dbtool: No such file or directory

I can't reproduce this problem -- are you still seeing this?


Comment 3 Thomas Fitzsimmons 2007-03-26 15:07:10 UTC
(In reply to comment #2)

> (In reply to comment #0)
> > Description of problem:
> > i.e. rpm install gives...
> > 
> > [root@Jehannum rpms]# rpm --upgrade java-1.5.0-gcj-*
> > /usr/bin/rebuild-gcj-db: line 6: /bin/gcj-dbtool: No such file or directory
> > dirname: missing operand
> > Try `dirname --help' for more information.
> > mkdir: missing operand
> > Try `mkdir --help' for more information.
> > /usr/bin/rebuild-gcj-db: line 13: /bin/gcj-dbtool: No such file or directory
> > xargs: /bin/gcj-dbtool: No such file or directory
> > /usr/bin/rebuild-gcj-db: line 6: /bin/gcj-dbtool: No such file or directory
> > /usr/bin/rebuild-gcj-db: line 6: /bin/gcj-dbtool: No such file or directory
> > dirname: missing operand
> > Try `dirname --help' for more information.
> > mkdir: missing operand
> > Try `mkdir --help' for more information.
> > /usr/bin/rebuild-gcj-db: line 13: /bin/gcj-dbtool: No such file or directory
> > xargs: /bin/gcj-dbtool: No such file or directory
> > /usr/bin/rebuild-gcj-db: line 6: /bin/gcj-dbtool: No such file or directory
> 
> I can't reproduce this problem -- are you still seeing this?

I couldn't reproduce it with local builds, but I am seeing it in the newly-built
Rawhide packages.  I'm working on a fix.


Comment 4 Thomas Fitzsimmons 2007-03-26 17:27:57 UTC
(In reply to comment #0)
> Description of problem:
> i.e. rpm install gives...
> 
> [root@Jehannum rpms]# rpm --upgrade java-1.5.0-gcj-*
> /usr/bin/rebuild-gcj-db: line 6: /bin/gcj-dbtool: No such file or directory
> dirname: missing operand
> Try `dirname --help' for more information.
> mkdir: missing operand
> Try `mkdir --help' for more information.
> /usr/bin/rebuild-gcj-db: line 13: /bin/gcj-dbtool: No such file or directory
> xargs: /bin/gcj-dbtool: No such file or directory
> /usr/bin/rebuild-gcj-db: line 6: /bin/gcj-dbtool: No such file or directory
> /usr/bin/rebuild-gcj-db: line 6: /bin/gcj-dbtool: No such file or directory
> dirname: missing operand
> Try `dirname --help' for more information.
> mkdir: missing operand
> Try `mkdir --help' for more information.
> /usr/bin/rebuild-gcj-db: line 13: /bin/gcj-dbtool: No such file or directory
> xargs: /bin/gcj-dbtool: No such file or directory
> /usr/bin/rebuild-gcj-db: line 6: /bin/gcj-dbtool: No such file or directory

Fixed in Rawhide.



Note You need to log in before you can comment on or make changes to this bug.