Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233934 - The patch "xen: Add PACKET_AUXDATA cmsg" cause /usr/include/linux/if_packet.h broken
Summary: The patch "xen: Add PACKET_AUXDATA cmsg" cause /usr/include/linux/if_packet.h...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Neil Horman
QA Contact: Martin Jenner
URL:
Whiteboard:
: 236913 236914 241496 (view as bug list)
Depends On:
Blocks: 238749 239547
TreeView+ depends on / blocked
 
Reported: 2007-03-26 02:13 UTC by Fang Wenqi
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 19:45:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
Include linux/types.h for __u32. (deleted)
2007-03-26 10:17 UTC, Herbert Xu
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0959 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5 Update 1 2007-11-08 00:47:37 UTC

Description Fang Wenqi 2007-03-26 02:13:19 UTC
Description of problem:
   After RHEL5 kernel-headers-2.6.18-8.1.1.el5 installed, I fail to
build tcpdump-3.9.4-8.1, it reports:
 /usr/include/linux/if_packet.h:52: error: expected specifier-qualifier-list
before '__u32


Version-Release number of selected component (if applicable):


How reproducible:
  Always.

Steps to Reproduce:
  1. Install kernel-headers-2.6.18-8.1.1.el5
  2. rpmbuild --rebuild tcpdump-3.9.4-8.1.src.rpm
 
Actual results:
+ DEFS='-g -D_U_="" -fPIC -DHAVE_CONFIG_H -D_FILE_OFFSET_BITS=64
-D_LARGEFILE_SOURCE'
+ make 'DEFS=-g -D_U_="" -fPIC -DHAVE_CONFIG_H -D_FILE_OFFSET_BITS=64
-D_LARGEFILE_SOURCE' LIBMAJOR=0 LIBMINOR=9 LIBSUBMINOR=4
gcc -O2 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=
generic -fasynchronous-unwind-tables -I.  -g -D_U_="" -fPIC -DHAVE_CONFIG_H
-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -fPIC -DPIC -
c ./pcap-linux.c
gcc -O2 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=
generic -fasynchronous-unwind-tables -I.  -g -D_U_="" -fPIC -DHAVE_CONFIG_H
-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -fPIC -DPIC -
c ./fad-getad.c
In file included from ./fad-getad.c:64:
/usr/include/linux/if_packet.h:52: error: expected specifier-qualifier-list
before '__u32'
make: *** [fad-getad.o] Error 1


Expected results:
  rpmbuild finished successfully.

Additional info:

checked /usr/include/linux/if_packet.h:52: 
 50 struct tpacket_auxdata
 51 {   
 52         __u32           tp_status;
 53         __u32           tp_len;
 54         __u32           tp_snaplen;
 55         __u16           tp_mac;
 56         __u16           tp_net;
 57 };

The code segment is introduced by kernel patch
linux-2.6-xen-add-packet_auxdata-cmsg.patch.
Maybe we have to define __u32 & __u16 for PACKET_AUXDATA in linux/types.h, and 
include it in linux/if_packet.h.

Comment 1 Herbert Xu 2007-03-26 10:17:53 UTC
Created attachment 150888 [details]
Include linux/types.h for __u32.

Thanks for the report.	This patch should fix the build problem.

Comment 2 Fang Wenqi 2007-03-27 01:40:18 UTC
succeed in rebuilding the package with above patch.

Thanks,
Fang Wenqi

Comment 3 Miroslav Lichvar 2007-04-18 14:00:37 UTC
*** Bug 236914 has been marked as a duplicate of this bug. ***

Comment 4 RHEL Product and Program Management 2007-04-24 20:45:35 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 5 RHEL Product and Program Management 2007-04-26 19:22:06 UTC
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.

Comment 6 Don Zickus 2007-05-01 18:10:41 UTC
in 2.6.18-17.el5

Comment 7 Marcela Mašláňová 2007-05-02 13:05:29 UTC
*** Bug 236913 has been marked as a duplicate of this bug. ***

Comment 12 Miroslav Lichvar 2007-05-28 08:20:36 UTC
*** Bug 241496 has been marked as a duplicate of this bug. ***

Comment 15 errata-xmlrpc 2007-11-07 19:45:12 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html



Note You need to log in before you can comment on or make changes to this bug.