Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233933 - pam-panel-icon doesn't insert itself into panel
Summary: pam-panel-icon doesn't insert itself into panel
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-26 01:26 UTC by Roman Ekjanov
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-27 00:40:33 UTC


Attachments (Terms of Use)
ps ax output (deleted)
2007-03-26 14:19 UTC, Roman Ekjanov
no flags Details

Description Roman Ekjanov 2007-03-26 01:26:54 UTC
Description of problem:
When pam-panel-icon is running, it creates a very small, but resizible, regular
window on the current desktop. The shield icon appears in that window.

Version-Release number of selected component (if applicable):
usermode-gtk-1.87-3
gnome-panel-2.16.3-2

How reproducible:
Always

Steps to Reproduce:
1. start gnome terminal (it makes pam-panel-icon start )
2.
3.
  
Actual results:
Small regular window on desktop. The shield icon in the window.

Expected results:
No extra windows on desktop. The shield icon in panel.

Additional info:
Probably, related to
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=167267

Comment 1 Roman Ekjanov 2007-03-26 01:35:25 UTC
This window shows up in the windows list. It cannot be closed. If pam-panel-icon
is killed, the window re-appears again, after pam-panel-icon restarts.


Comment 2 Miloslav Trmač 2007-03-26 13:22:44 UTC
Thanks for your report.  Unfortunately I can't reproduce the behavior.

* What desktop environment are you using?
* If GNOME, do you have a "notification area" applet on your panel?
* Do other applications that use notification icons (e.g. gaim, rhytmbox,
  gnome-power-manager) embed them into the panel correctly?
* Is a pam-panel-icon process running before you start gnome-terminal?


Comment 3 Roman Ekjanov 2007-03-26 14:19:15 UTC
Created attachment 150902 [details]
ps ax output

Comment 4 Roman Ekjanov 2007-03-26 14:20:59 UTC
* GNOME
* Yes (set ps ax output)
* No. I tried gaim. So it is, probably, a notification area problem
* No


Comment 5 Ray Strode [halfline] 2007-03-26 14:48:55 UTC
do you have a notification area on your panel?

Comment 6 Roman Ekjanov 2007-03-27 00:40:33 UTC
My bad. I thought that if notification-area-applet is running, it is inserted.
Apparently, it is two different things. I have to apologize for the false alert.


Note You need to log in before you can comment on or make changes to this bug.