Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233932 - SATA disks not seen at install
Summary: SATA disks not seen at install
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
Whiteboard: bzcl34nup
Depends On:
TreeView+ depends on / blocked
Reported: 2007-03-26 00:10 UTC by Wayne Stidolph
Modified: 2008-08-02 23:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-05-07 01:21:18 UTC

Attachments (Terms of Use)

Description Wayne Stidolph 2007-03-26 00:10:26 UTC
Description of problem:
SATA disks are lost during boot ... so, F7 Test 2 installer gets to disk
selection and shows no disks available

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install from DVD
Actual results:
Install target disk list is empty.

Expected results:
Disk shows as selectable target for install/partition/format.

Additional info:
MB is Elite P965T- rev 1.0B with BIOS 1.0h (latest, 2/6/2007). A with intel 965
chipset, with ICH8 Southbridge and JMicron SATAII ports. JMicron BIOS is 1.06.63.

Drive (Seagate 300GB) is seen in BIOS (both JMicron or main), but is not seen in
Linux installer. Have tried in SATA modes of IDE and ACPI+IDE, on both JMicron
and ICH8 ports (no change) Tried "acpi=off apm=on noapic" boot params but then
the DVD drive (which is IDE, on the JMicron) isn't seen anymore.

Comment 1 Matthew Miller 2007-04-10 16:32:36 UTC
Fedora 7 test bugs should be filed against "devel", not against test1/2/3. This
isn't obvious, I know. Moving this report so it isn't lost.

This is a bulk message -- I apologize if this was actually meant to be targeted
against a different release. If so, please fix or let me know. Thanks.

Comment 2 Dave Jones 2007-04-23 18:02:55 UTC
This may have been due to the initrd not waiting for the disks to be discovered
before we tried mounting root.  Would be good if you can test the current tree,
or test4 when it comes out.

Comment 3 determan 2007-05-22 04:44:37 UTC
I also submitted this information (with additional info for FC6 and FC5) to 
bug ID 196979, but fixing it in Fedora 7 seems more important.

I am having the same problem (no disks found for installation) with the 
following system:

motherboard: ECS Elitegroup P965T V1.0B (P965 Northbridge, ICH8 Southbridge)
cpu: Intel Core2Duo E6400
hard disks: Maxtor SATA II 300 GB (2)
memory: 2 GB
bios: AwardBIOS v6.00PG

The BIOS sees the two identical drives as IDE Channel 0 Master and IDE Channel 
1 Master. I have tried setting the SATA2 controller to both IDE Mode and RAID 
Mode in the BIOS without making the disks visible to the Fedora Core installer.

I have tried three of the Fedora 7 test builds:

Fedora 7 Test 4 (F-6.93-x86_64-DVD):
The installer loads the pata_jmicron and ata_piix drivers.
Anaconda does not see any hard drives to use for the installation.

Fedora 7 Test 3 (F-6.92-x86_64-DVD):
The installer loads the pata_jmicron and ata_piix drivers.
Anaconda generates an exception at the point where it should present the drive 
installation options. I do not know how to save the exception details, but 
here is the traceback:

	File "/usr/lib/anaconda/iw/", line 286, in getScreen
	defaultBoot =[0]
	File "/usr/lib/anaconda/", line 1128, in setScreen
	new_screen = self.currentWindow.getScreen(anaconda)
	File "/usr/lib/anaconda/", line 1039, in nextClicked
	IndexError: list index out of range

Fedora 7 Test 1 (F-6.90-x86_64-DVD):
The installer loads the pata_jmicron and ata_piix drivers.
Anaconda does not see any hard drives to use for the installation.

I do not have a practical workaround for the problem, because the motherboard 
only has one IDE controller, and an IDE cable is not long enough to reach from 
the hard drive bay to the DVD drive bay in my Antec case.

Comment 4 determan 2007-06-04 04:53:01 UTC
Same behavior observed with Fedora 7 on same system:

Fedora 7 (F-7-x86_64-DVD):
The installer loads the pata_jmicron and ata_piix drivers.
Anaconda does not see any hard drives to use for the installation.

Comment 5 Bug Zapper 2008-04-03 23:48:52 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:

We will be following the process here: to ensure this
doesn't happen again.

Comment 6 Bug Zapper 2008-05-07 01:21:17 UTC
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:

Note You need to log in before you can comment on or make changes to this bug.