Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233925 - broken pkgconfig file
Summary: broken pkgconfig file
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: compat-libosip2
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeffrey C. Ollie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-25 21:09 UTC by Patrice Dumas
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-17 15:59:17 UTC


Attachments (Terms of Use)
correct pkgconfig file (deleted)
2007-03-25 23:55 UTC, Patrice Dumas
no flags Details | Diff
corresponding spec file patch (deleted)
2007-03-25 23:56 UTC, Patrice Dumas
no flags Details | Diff

Description Patrice Dumas 2007-03-25 21:09:51 UTC
Description of problem:
 
The cflags is not right, since the includedir is missing:
pkg-config --cflags libosip2-2.2.2
-DOSIP_MT  
should be 
-I/usr/include/osip2-2.2.2 -DOSIP_MT

I guess that one should have
Cflags: -I${includedir} -DOSIP_MT

I can do a patch if you want.

Version-Release number of selected component (if applicable):

compat-libosip2-2.2.2-9.fc7

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Patrice Dumas 2007-03-25 21:11:27 UTC
This is unrelated, but I suggest using
sed -i.compat -e
instead of
%{__perl} -pi.compat -e

Comment 2 Patrice Dumas 2007-03-25 22:01:33 UTC
I verified that the same bug is present in libosip2.pc too
(although it cannot show up in fedora), I won't open another 
bug, though.

Comment 3 Jeffrey C. Ollie 2007-03-25 23:34:30 UTC
That'd be great if you could generate a patch...

Comment 4 Patrice Dumas 2007-03-25 23:55:57 UTC
Created attachment 150863 [details]
correct pkgconfig file

Comment 5 Patrice Dumas 2007-03-25 23:56:37 UTC
Created attachment 150864 [details]
corresponding spec file patch

Comment 6 Patrice Dumas 2007-03-26 00:01:26 UTC
Also unrelated, I don't think that %{?dist} should be in the
Provides: and Obsoletes:, otherwise the obsoleted version
will depend on the current %{?dist} value which is wrong 
(it is less problematic for the Provides:).

I also thing that those Provides and Obsoletes shouldn't be
there. Provides are automatically handled by the dependencies 
on the soname, and, in my opinion, upgrading from a previous
version should lead to the latest version, not the compat-
package.

Comment 7 Jeffrey C. Ollie 2007-04-17 15:59:17 UTC
Fixed in compat-libosip2-2.2.2-11


Note You need to log in before you can comment on or make changes to this bug.