Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233924 - GLcore segfault in XMesaResizeBuffers
Summary: GLcore segfault in XMesaResizeBuffers
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: rawhide
Hardware: ppc64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-25 21:03 UTC by Chris Lumens
Modified: 2018-04-11 10:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-19 12:05:09 UTC


Attachments (Terms of Use)
X log file (deleted)
2007-03-25 21:03 UTC, Chris Lumens
no flags Details
xorg.conf (deleted)
2007-03-26 15:56 UTC, Chris Lumens
no flags Details

Description Chris Lumens 2007-03-25 21:03:57 UTC
With today's rawhide tree, I'm see the following crash randomly.  It seems to
happen when I click something in Firefox.  It's reproducible - just use the
browser normally for a while - but I don't know exactly what I'm doing to cause it.

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x94) [0x1008dd24]
1: [0x100344]
2: /usr/bin/Xorg(SmartScheduleTime+0) [0x1021c18c]
3: /usr/lib/xorg/modules/extensions//libGLcore.so(XMesaResizeBuffers+0x30)
[0xe3df000]
4: /usr/lib/xorg/modules/extensions//libGLcore.so [0xe424db8]
5: /usr/lib/xorg/modules/extensions//libglx.so [0xe78e308]
6: /usr/bin/Xorg(compPositionWindow+0x84) [0x100d28b4]
7: /usr/bin/Xorg(ResizeChildrenWinSize+0x1ec) [0x1002fb3c]
8: /usr/bin/Xorg(miSetShape+0xfc) [0x1010a7cc]
9: /usr/bin/Xorg [0x10117178]
10: /usr/bin/Xorg [0x10117a08]
11: /usr/bin/Xorg [0x101277c0]
12: /usr/bin/Xorg(Dispatch+0x240) [0x100455e0]
13: /usr/bin/Xorg(main+0x440) [0x10027e00]
14: /lib/libc.so.6 [0xfe3dd6c]
15: /lib/libc.so.6(__libc_start_main+0x144) [0xfe3dfa4]

Fatal server error:
Caught signal 11.  Server aborting

Comment 1 Chris Lumens 2007-03-25 21:03:57 UTC
Created attachment 150862 [details]
X log file

Comment 2 Matěj Cepl 2007-03-26 15:53:52 UTC
Hi, Chris,

could we get you /etc/X11/xorg.conf as well (if there is any), please?

Thanks,

Matěj

Comment 3 Chris Lumens 2007-03-26 15:56:48 UTC
Created attachment 150907 [details]
xorg.conf

Comment 4 Adam Jackson 2007-03-28 18:17:34 UTC
I'm calling the SmartScheduleTime in the backtrace a bogon, since that's a
variable not a function.

Comment 5 Adam Jackson 2007-08-14 15:33:34 UTC
This bug is believed to be fixed as of xorg-x11-server 1.3.0.0-19.fc8, in
tomorrow's rawhide.  Please update, and move this bug back to ASSIGNED if the
issue still occurs for you.

Comment 6 Matěj Cepl 2007-09-19 12:05:09 UTC
Reporter, if this bug has not been fixed with the mentioned package (or any
later release), please, reopen this bug with additional information. Thank you.


Note You need to log in before you can comment on or make changes to this bug.