Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233854 - on upgrade removes sun's jdk
Summary: on upgrade removes sun's jdk
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xml-commons-apis
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matt Wringe
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-25 15:56 UTC by Marius Andreiana
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-25 20:40:41 UTC


Attachments (Terms of Use)

Description Marius Andreiana 2007-03-25 15:56:42 UTC
Updating  : xml-commons-apis             ####################### [ 6/38] 
  Cleanup   : xml-commons-apis             ####################### [19/38]
  Removing  : jdk                          ####################### [20/38]
  Removing  : xml-commons                  ####################### [21/38]

 rpm -q xml-commons-apis
xml-commons-apis-1.3.03-0jpp.1.fc7

Comment 1 Matt Wringe 2007-03-25 18:09:52 UTC
This is due to the Sun JDK rpm providing xml-commons-apis. Currently rpm behaves
in this manner: whenever a package is updated, it will also remove all packages
that provide that package name
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=233713).

This is not a bug with the xml-commons-apis package, but an issue with mixing
rpms from different sources. For example, if you were using GCJ from the Fedora
repositories you would not have this issue.

We cannot control the behaviour of thirdparty rpms. Ideally the JDK rpm should
not be providing xml-commons-apis, as their concept of xml-commons-apis
conflicts with the Fedora concept (our version installs xml-commons-apis.jar
which is used by many other programs). If you really want this fixed, then you
will need to file bugs with Sun to make their JDK rpm compatible with Fedora.

jpackage.org provides a nonsrc jdk rpm (that you will have to build yourself)
that might work. But this is also an external rpm that Fedora will not support.

That being said, I will see what can be done to prevent the removal of the JDK
rpm. But please note that this is not a trivial change, and it may not be
approved since its really a problem with the JDK rpm. 

Please file the bugs with Sun.

Comment 2 Marius Andreiana 2007-03-25 20:40:41 UTC
Thanks Matt for the detailed comments. 

As a workaround for now, I assume one can rebuild jdk with src.rpm from
http://jpackage.org/ and avoid this.
Long term, the open source jdk should be released by Sun and rebuilt by Fedora.

I will close this since Fedora effort would be better spent on Fedora.


Note You need to log in before you can comment on or make changes to this bug.