Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233851 - resolveip fails on hostnames with a leading digit
Summary: resolveip fails on hostnames with a leading digit
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: mysql
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tom Lane
QA Contact: David Lawrence
URL: http://bugs.mysql.com/bug.php?id=27427
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-25 13:32 UTC by Kasper Dupont
Modified: 2013-07-03 03:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-26 17:34:53 UTC


Attachments (Terms of Use)
Fix the bug by using inet_aton rather than the obsolete inet_addr function (deleted)
2007-03-25 13:32 UTC, Kasper Dupont
no flags Details | Diff

Description Kasper Dupont 2007-03-25 13:32:15 UTC
Description of problem:
resolveip produce incorrect result if given a hostname starting with a digit

Version-Release number of selected component (if applicable):
mysql-server-5.0.27-1.fc5

How reproducible:
Happens every time.

Steps to Reproduce:
1. resolveip 42.kasperd.net
  
Actual results:
Broadcast

Expected results:
IP address of 42.kasperd.net is 80.167.222.169

Comment 1 Kasper Dupont 2007-03-25 13:32:16 UTC
Created attachment 150849 [details]
Fix the bug by using inet_aton rather than the obsolete inet_addr function

Comment 2 Tom Lane 2007-03-25 18:39:56 UTC
I would suggest filing this upstream at bugs.mysql.com --- AFAICS it is not a bug in our packaging of 
mysql.

Comment 3 Colin Charles 2007-03-26 16:07:02 UTC
It isn't a Fedora fault, and upstream URL is here now.

Comment 4 Tom Lane 2007-03-26 17:34:53 UTC
Thanks for filing it with the proper people.


Note You need to log in before you can comment on or make changes to this bug.