Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233800 - Mouse /dev/input/eventX changes from X=1 to X=2 going from 2.6.19 to 2.6.20
Summary: Mouse /dev/input/eventX changes from X=1 to X=2 going from 2.6.19 to 2.6.20
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-25 05:34 UTC by Need Real Name
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-27 20:06:03 UTC


Attachments (Terms of Use)

Description Need Real Name 2007-03-25 05:34:25 UTC
In order to get the horizontal tilt working on my mouse (Microsoft Wireless
Optical Desktop 5000), I have been adding the following lines to the mouse
stanza in /etc/X11/xorg.conf:

     # Driver      "mouse"
     # Option      "Device" "/dev/input/mice"
     # Added for Microsoft tilt mouse
        Driver      "evdev"
        Option      "Device" "/dev/input/event1"

However, starting in kernel 2.6.20, this now CRASHES the X-Server on startup.
Instead (for some unknown reason), it now only works if I use /dev/input/event2
instead.

What the heck changed between 2.6.19 and 2.6.20 to cause this?

I wouldn't think that I should have to change my xorg.conf file just due to a
kernel update (and if that is required, then it should be documented or fixed
automatically!)

I am getting very frustrated with the QUALITY CONTROL and REGRESSION TESTING of
kernel releases. On mid-release updates to a stable distro like FC6, I would not
expect an 'update' to break so many critical pieces. So far for me, this update
to 2.6.20 has broken SATA (since fixed), sound (still broken), dvb (supposedly
being fixed), and the mouse (fixed if you change the xorg.conf file). How can we
ever expect to get non-techies to adopt linux in general and Fedora in
particular if simple updates break so many pieces!!!!

Comment 1 Chuck Ebbert 2007-03-25 23:06:48 UTC
These kernels go into the updates-testing repository before release.
When nobody reports problems, they are released.


Comment 2 Chuck Ebbert 2007-03-27 20:06:03 UTC
According to the input subsystem maintainer, the mouse and event device
numbers have never been guaranteed to be stable.

You should be using "Phys" or "<map>Bits" options if you want stability.
Look at the manpage for evdev for more information.
 

Comment 3 Need Real Name 2007-03-27 23:53:49 UTC
OK -- that wasn't clear to me (since I had been using the event device numbers
based on an answer I found elsewhere on the web)

Actually, after reading the man pages more carefully, it seems that perhaps the
easiest/clearest (and best?) method if you have only one such mouse on the
system is to simply use the 'name' parameter that you can find in
/proc/bus/input/devices.

Thanks for helping me with this one


Note You need to log in before you can comment on or make changes to this bug.