Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233796 - Freshening perl requires perl-devel
Summary: Freshening perl requires perl-devel
Keywords:
Status: CLOSED DUPLICATE of bug 231549
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-25 01:13 UTC by Allen Kistler
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-26 14:35:53 UTC


Attachments (Terms of Use)

Description Allen Kistler 2007-03-25 01:13:00 UTC
Description of problem:
Freshening perl requires perl-devel

Version-Release number of selected component (if applicable):
perl-5.8.8-15.fc7.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. Freshen perl (rpm -F perl*)
  
Actual results:
perl-devel is needed by perl-5.8.8-15.fc7.i386

Expected results:
perl should not require perl-devel to install or freshen

Additional info:

Comment 1 Robin Norwood 2007-03-26 14:35:53 UTC
Thanks for the bug report, but this is a known issue.

Right now perl 'requires' perl-devel:


# XXX - remove this once RH bug #231549 is fixed
Requires:	perl-devel


Since that bug is fixed, I'll remove the requirement for the next build of
perl/perl-devel.

*** This bug has been marked as a duplicate of 231549 ***


Note You need to log in before you can comment on or make changes to this bug.