Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233781 - Start of system-config-users fails
Summary: Start of system-config-users fails
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-users
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
: 234702 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-24 23:46 UTC by Guido Ledermann
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-26 16:01:14 UTC


Attachments (Terms of Use)

Description Guido Ledermann 2007-03-24 23:46:39 UTC
Description of problem:
Doesn't start at all.

Version-Release number of selected component (if applicable):
system-config-users.noarch 0:1.2.53-1.fc7

How reproducible:
Anytime.

Steps to Reproduce:
1. run "system-config-users" from a console or similar as root.
or
2. Start it from the Administrators menu
  
Actual results:
Traceback (most recent call last):
  File "/usr/share/system-config-users/system-config-users.py", line 36, in <module>
    translate.textdomain ("system-config-users")
  File "/usr/lib/python2.5/site-packages/rhpl/translate.py", line 220, in textdomain
    cat.setDomain(domain)
  File "/usr/lib/python2.5/site-packages/rhpl/translate.py", line 106, in setDomain
    self.updateCachedCatPaths()
  File "/usr/lib/python2.5/site-packages/rhpl/translate.py", line 140, in
updateCachedCatPaths
    catalog = gettext.GNUTranslations(mofile)
  File "/usr/lib/python2.5/gettext.py", line 180, in __init__
    self._parse(fp)
  File "/usr/lib/python2.5/gettext.py", line 315, in _parse
    self.plural = c2py(plural)
  File "/usr/lib/python2.5/gettext.py", line 90, in c2py
    'plural forms expression error, maybe unbalanced parenthesis'
ValueError: plural forms expression error, maybe unbalanced parenthesis

Comment 1 Nils Philippsen 2007-03-26 10:08:22 UTC
With which language setting do you try to start s-c-users, what does the command
"locale" give?

Comment 2 Guido Ledermann 2007-03-26 11:33:33 UTC
"locale" gives
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=


Comment 3 Nils Philippsen 2007-03-26 16:01:14 UTC
system-config-date-1.2.54 is building right now which contains changes to the
plural specification for German, this should fix your problem. Please test once
it hits the mirrors and reopen if the problem still persists with the new version.

Comment 4 Nils Philippsen 2007-04-12 10:45:07 UTC
*** Bug 234702 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.