Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233774 - crash on startup
Summary: crash on startup
Keywords:
Status: CLOSED DUPLICATE of bug 227192
Alias: None
Product: Fedora
Classification: Fedora
Component: abiword
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marc Maurer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-24 22:00 UTC by Andrew Overholt
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-30 11:31:46 UTC


Attachments (Terms of Use)

Description Andrew Overholt 2007-03-24 22:00:06 UTC
Description of problem:


Version-Release number of selected component (if applicable):
abiword-1:2.4.6-3.fc7.i386

How reproducible:
Always

Steps to Reproduce:
1. run abiword (terminal or menu)
  
Actual results:
Crash.  Nothing in terminal.

Expected results:
No crash.

Additional info:
Here's the stacktrace given by bug-buddy:

System: Linux 2.6.20-1.2949.fc7 #1 SMP Mon Feb 26 18:37:35 EST 2007 i686
X Vendor: The X.Org Foundation
X Vendor Release: 70200000
Selinux: Enforcing
Accessibility: Disabled

Memory status: size: 65372160 vsize: 0 resident: 65372160 share: 0 rss: 19943424
rss_rlim: 0
CPU usage: start_time: 1173284396 rtime: 0 utime: 50 stime: 0 cutime:36 cstime:
0 timeout: 14 it_real_value: 0 frequency: 0

Backtrace was generated from '/usr/bin/AbiWord-2.4'

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
[ a whole bunch more of these ]
[Thread debugging using libthread_db enabled]
[New Thread -1208551712 (LWP 3336)]
(no debugging symbols found)
[ a whole bunch more of these ]
0x00927402 in __kernel_vsyscall ()
#0  0x00927402 in __kernel_vsyscall ()
#1  0x00e29bd3 in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x007c4326 in ?? () from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x00927402 in __kernel_vsyscall ()
#5  0x01071f60 in raise () from /lib/libc.so.6
#6  0x010737b1 in abort () from /lib/libc.so.6
#7  0x0813fcf7 in AP_UnixApp::catchSignals ()
#8  0x0813fd8a in signalWrapper ()
#9  <signal handler called>
#10 0x0824de77 in XAP_UnixFont::getName ()
#11 0x08273c4e in GR_UnixGraphics::getGUIFont ()
#12 0x08272184 in GR_UnixGraphics::setZoomPercentage ()
#13 0x08144a8e in AP_UnixFrame::_createViewGraphics ()
#14 0x081671e3 in AP_Frame::_showDocument ()
#15 0x0816779a in AP_Frame::loadDocument ()
#16 0x08166987 in AP_Frame::loadDocument ()
#17 0x0814812f in AP_App::openCmdLineFiles ()
#18 0x081429e3 in AP_UnixApp::main ()
#19 0x0813e9aa in main ()

Thread 1 (Thread -1208551712 (LWP 3336)):
#0  0x00927402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00e29bd3 in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x007c4326 in ?? () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x00927402 in __kernel_vsyscall ()
No symbol table info available.
#5  0x01071f60 in raise () from /lib/libc.so.6
No symbol table info available.
#6  0x010737b1 in abort () from /lib/libc.so.6
No symbol table info available.
#7  0x0813fcf7 in AP_UnixApp::catchSignals ()
No symbol table info available.
#8  0x0813fd8a in signalWrapper ()
No symbol table info available.
#9  <signal handler called>
No symbol table info available.
#10 0x0824de77 in XAP_UnixFont::getName ()
No symbol table info available.
#11 0x08273c4e in GR_UnixGraphics::getGUIFont ()
No symbol table info available.
#12 0x08272184 in GR_UnixGraphics::setZoomPercentage ()
No symbol table info available.
#13 0x08144a8e in AP_UnixFrame::_createViewGraphics ()
No symbol table info available.
#14 0x081671e3 in AP_Frame::_showDocument ()
No symbol table info available.
#15 0x0816779a in AP_Frame::loadDocument ()
No symbol table info available.
#16 0x08166987 in AP_Frame::loadDocument ()
No symbol table info available.
#17 0x0814812f in AP_App::openCmdLineFiles ()
No symbol table info available.
#18 0x081429e3 in AP_UnixApp::main ()
No symbol table info available.
#19 0x0813e9aa in main ()
No symbol table info available.
#0  0x00927402 in __kernel_vsyscall ()
The program is running.  Quit anyway (and detach it)? (y or n) [answered Y;
input not from terminal]

Comment 1 Marc Maurer 2007-03-30 11:31:46 UTC

*** This bug has been marked as a duplicate of 227192 ***


Note You need to log in before you can comment on or make changes to this bug.