Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233773 - Tasks crash on close of evolution
Summary: Tasks crash on close of evolution
Keywords:
Status: CLOSED DUPLICATE of bug 232691
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-24 21:53 UTC by Andrew Overholt
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-24 21:55:14 UTC


Attachments (Terms of Use)

Description Andrew Overholt 2007-03-24 21:53:49 UTC
Description of problem:
Every time I close evolution, I get a bug buddy dialogue about Tasks crashing. 
It claims that bugzilla.gnome.org doesn't track Tasks bugs.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open evolution
2. Close evolution
  
Actual results:
Crash dialogue

Expected results:
No crash dialogue

Additional info:
Stack trace:

Distribution: Fedora release 6.92 (Rawhide)
Gnome Release: 2.18.0 2007-03-20 (Red Hat, Inc)
BugBuddy Version: 2.18.0

System: Linux 2.6.20-1.3003.fc7 #1 SMP Wed Mar 21 18:57:31 EDT 2007 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10299902
Selinux: Permissive
Accessibility: Disabled
GTK+ Theme: Clearlooks
Icon Theme: Clearlooks

Memory status: size: 204591104 vsize: 204591104 resident: 71536640 share:
22560768 rss: 71536640 rss_rlim: 4294967295
CPU usage: start_time: 1174769417 rtime: 14988 utime: 11838 stime: 3150
cutime:62 cstime: 116 timeout: 0 it_real_value: 0 frequency: 100

Backtrace was generated from '/usr/bin/evolution'

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
[ a whole bunch of these ]
[Thread debugging using libthread_db enabled]
[New Thread -1208989456 (LWP 8175)]
[New Thread -1246442608 (LWP 8907)]
[New Thread -1273336944 (LWP 8380)]
(no debugging symbols found)
[ a whole bunch more "no debuginfo found" entries ]
0x0030b402 in __kernel_vsyscall ()
#0  0x0030b402 in __kernel_vsyscall ()
#1  0x00713bfb in waitpid () from /lib/libpthread.so.0
#2  0x0044aa46 in ?? () from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x0030b402 in __kernel_vsyscall ()
#5  0x01409ee0 in raise () from /lib/libc.so.6
#6  0x0140b731 in abort () from /lib/libc.so.6
#7  0x00860f55 in ?? () from /lib/libdbus-1.so.3
#8  0x0085cee6 in ?? () from /lib/libdbus-1.so.3
#9  0x00844550 in dbus_connection_unref () from /lib/libdbus-1.so.3
#10 0x0027ffba in ?? () from /usr/lib/libnm_glib.so.0
#11 0x08050fc0 in e_shell_nm_glib_dispose ()
#12 0x0805c9f1 in ?? ()
#13 0x0077c420 in g_object_run_dispose () from /lib/libgobject-2.0.so.0
#14 0x010f81ce in gtk_object_destroy () from /usr/lib/libgtk-x11-2.0.so.0
#15 0x011f4495 in gtk_widget_destroy () from /usr/lib/libgtk-x11-2.0.so.0
#16 0x08053532 in e_shell_close_all_windows ()
#17 0x08053694 in ?? ()
#18 0x0136dbf6 in ?? () from /lib/libglib-2.0.so.0
#19 0x0136d622 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#20 0x013705ff in ?? () from /lib/libglib-2.0.so.0
#21 0x013709a9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#22 0x0050e7e3 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#23 0x0805ebc6 in main ()

Thread 3 (Thread -1273336944 (LWP 8380)):
#0  0x0030b402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x014a6a83 in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x01370633 in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#3  0x013709a9 in g_main_loop_run () from /lib/libglib-2.0.so.0
No symbol table info available.
#4  0x00d284e0 in ?? () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#5  0x0138b49f in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#6  0x0070c2db in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#7  0x014b06fe in clone () from /lib/libc.so.6
No symbol table info available.

Thread 2 (Thread -1246442608 (LWP 8907)):
#0  0x0030b402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x014a6a83 in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x01370633 in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#3  0x013709a9 in g_main_loop_run () from /lib/libglib-2.0.so.0
No symbol table info available.
#4  0x001df6a2 in ?? () from /usr/lib/libebook-1.2.so.9
No symbol table info available.
#5  0x0138b49f in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#6  0x0070c2db in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#7  0x014b06fe in clone () from /lib/libc.so.6
No symbol table info available.

Thread 1 (Thread -1208989456 (LWP 8175)):
#0  0x0030b402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00713bfb in waitpid () from /lib/libpthread.so.0
No symbol table info available.
#2  0x0044aa46 in ?? () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x0030b402 in __kernel_vsyscall ()
No symbol table info available.
#5  0x01409ee0 in raise () from /lib/libc.so.6
No symbol table info available.
#6  0x0140b731 in abort () from /lib/libc.so.6
No symbol table info available.
#7  0x00860f55 in ?? () from /lib/libdbus-1.so.3
No symbol table info available.
#8  0x0085cee6 in ?? () from /lib/libdbus-1.so.3
No symbol table info available.
#9  0x00844550 in dbus_connection_unref () from /lib/libdbus-1.so.3
No symbol table info available.
#10 0x0027ffba in ?? () from /usr/lib/libnm_glib.so.0
No symbol table info available.
#11 0x08050fc0 in e_shell_nm_glib_dispose ()
No symbol table info available.
#12 0x0805c9f1 in ?? ()
No symbol table info available.
#13 0x0077c420 in g_object_run_dispose () from /lib/libgobject-2.0.so.0
No symbol table info available.
#14 0x010f81ce in gtk_object_destroy () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#15 0x011f4495 in gtk_widget_destroy () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#16 0x08053532 in e_shell_close_all_windows ()
No symbol table info available.
#17 0x08053694 in ?? ()
No symbol table info available.
#18 0x0136dbf6 in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#19 0x0136d622 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
No symbol table info available.
#20 0x013705ff in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#21 0x013709a9 in g_main_loop_run () from /lib/libglib-2.0.so.0
No symbol table info available.
#22 0x0050e7e3 in bonobo_main () from /usr/lib/libbonobo-2.so.0
No symbol table info available.
#23 0x0805ebc6 in main ()
No symbol table info available.
#0  0x0030b402 in __kernel_vsyscall ()
The program is running.  Quit anyway (and detach it)? (y or n) [answered Y;
input not from terminal]


----------- .xsession-errors ---------------------
Most likely, the application was supposed to call dbus_connection_close(), since
this is a private connection.
  D-Bus not built with -rdynamic so unable to print a backtrace
warning: the debug information found in
"/usr/lib/debug//usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-xpm.so.debug"
does not match "/usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-xpm.so" (CRC misma
warning: the debug information found in
"/usr/lib/debug//usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so.debug"
does not match "/usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so" (CRC misma
warning: the debug information found in
"/usr/lib/debug//usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-gif.so.debug"
does not match "/usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-gif.so" (CRC misma
--------------------------------------------------

Comment 1 Matthew Barnes 2007-03-24 21:55:14 UTC

*** This bug has been marked as a duplicate of 232691 ***


Note You need to log in before you can comment on or make changes to this bug.