Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233751 - GDB lacks support to debug XFree86
Summary: GDB lacks support to debug XFree86
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gdb
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jan Kratochvil
QA Contact:
URL:
Whiteboard:
Depends On: 110262
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-24 17:27 UTC by Jan Kratochvil
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-26 02:01:49 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Kratochvil 2007-03-24 17:27:03 UTC
+++ This bug was initially created as a clone of Bug #110262 +++

Description of problem:
I'm trying to debug some XFree86 issues I'm having with the Radeon
driver, and I've found that gdb lacks the ability to debug XFree86. 
We found a debugger that worked in RHL8, x86 hardware from
people.redhat.com, but we'd like to move the cluster to RHEL3.  I'd
like to file an RFE to have RHEL3's debugger be able to debug XFree86.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RHEL3
2. Experience XFree86 problems with Radeon DRI
3. Attempt to debug XFree86
    

Actual Results:  Unable to debug, gdb has not the capability.

Expected Results:  The ability to debug XFree86 using gdb.

-- Additional comment from shillman@redhat.com on 2003-11-17 16:02 EST --
RFE logged as internal bug #110283 - will consider for future releases.

-- Additional comment from jkeating@j2solutions.net on 2003-11-17 16:04 EST --
Is that future RHEL releases, or future gdb releases?

-- Additional comment from jan.kratochvil@redhat.com on 2007-03-24 13:25 EST --
RHEL3 and RHEL4 were IIRC using for X the custom crossplatform driver loaded (.o
based) and so a specific GDB support would be needed.
Since RHEL5 Xorg uses a standard mapped .so libraries where no specific GDB
support is needed.
RHEL3.9 is being closed now and while no 3ACK process was applied to this Bug
there is not much time left to consider its implementation.
I also believe it is not worth the implementation without any ITs and the
functionality limitation only to RHEL3/RHEL4 now.

Comment 1 Andrew Cagney 2007-03-26 01:59:12 UTC
Fixed in RHEL 5.

Comment 2 RHEL Product and Program Management 2007-03-26 02:01:49 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 


Note You need to log in before you can comment on or make changes to this bug.