Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233749 - kernel-xen sporadically reboots
Summary: kernel-xen sporadically reboots
Keywords:
Status: CLOSED DUPLICATE of bug 233937
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-xen
Version: 6
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Xen Maintainance List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-24 16:57 UTC by Bernard Johnson
Modified: 2007-11-30 22:12 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-04 13:47:34 UTC


Attachments (Terms of Use)

Description Bernard Johnson 2007-03-24 16:57:04 UTC
Description of problem:
kernel-xen will sporadically reboot after a few minutes of use.

Version-Release number of selected component (if applicable):
kernel-xen-2.6.20-1.2933.fc6

How reproducible:
very

Steps to Reproduce:
1. login in (gui - gdm)
2. run a few things, usually less than 2 minutes
3. watch reboot
  
Additional info:
There is nothing in the log files that indicate a failure.  This did not happen
with kernel-xen-2.6.19-1.2911.6.5.fc6.  The non-xen kernel appears to be
completely stable, so far.

Comment 1 Claus Reheis 2007-03-24 23:07:49 UTC
Same here!

Smolt Profile of my machine:
[url]http://smolt.fedoraproject.org/show?UUID=69efaca1-fec5-4ce1-9d1c-abc7b6902e52[/url]

Comment 2 Jan ONDREJ 2007-03-28 06:44:14 UTC
Exactyly same problem with all of my three machines (notebook and 2 virtual
servers). Each machine hangs in different times (from 15 mins. to 3 days), but
all of them hangs finally.

Another problem is, that some applications hangs before (for example apcsmart
daemon from nut package hangs after some minutes (1-2?).


Comment 3 Scott Sanders 2007-04-02 13:15:43 UTC
Same here. Tested on a Dell 2850 and an HP Proliant DL380. I believe this is due
to memory corruption caused by the Xen patches. According to Xen developers I
have spoken to, the 2.6.20 kernel is not fully supported by Xen yet and likely
should not be included in the yum repositories. To rapidly duplicate the
problem, install iozone and let it run for a few minutes (seconds). The machine
will hang and then reboot. Building the Xen kernel from mercurial sources works
terrific on an identical fc6 installation, leading me to blieve the problem is
in the 2.6.20 kernel-xen package.

Comment 4 Eduardo Habkost 2007-04-02 13:55:27 UTC
This looks like a duplicate of bug #233937

Comment 5 Eduardo Habkost 2007-04-04 13:47:34 UTC
This has the same symptoms of bug #233937 and are likely to have the same 
cause, so marking as duplicate of it.

If after fixing one problem some people continue getting the problems (that 
will mean they had different causes), we divide the bugs again.

*** This bug has been marked as a duplicate of 233937 ***

Comment 6 Rolf Fokkens 2007-04-04 21:08:54 UTC
Same problem here with kernel-xen-2.6.20-1.2933.fc6, haven't reverted to older
kernels to see if those fix the problem.

Hardware: CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 3600+, 1.5 GB RAM


Note You need to log in before you can comment on or make changes to this bug.