Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233746 - pstack can cause process to suspend
Summary: pstack can cause process to suspend
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gdb
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jan Kratochvil
QA Contact:
URL:
Whiteboard:
Depends On: 189607
Blocks: 292971 483262
TreeView+ depends on / blocked
 
Reported: 2007-03-24 15:29 UTC by Jan Kratochvil
Modified: 2009-01-30 16:18 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0811
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-15 16:11:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0811 normal SHIPPED_LIVE gdb bug fix update 2007-11-14 17:46:14 UTC

Description Jan Kratochvil 2007-03-24 15:29:54 UTC
+++ This bug was initially created as a clone of Bug #189607 +++

gdb-6.3.0.0-1.132.EL4.x86_64
kernel-smp-2.6.9-42.0.10.EL.x86_64

First terminal:
- compile signal_test:
gcc -Wall -g -o signal_test signal_test.c
- run signal_test

Second terminal:
- killall -ALRM signal_test
- while true ; do pstack `pidof signal_test` > /dev/null ; done

Let it run for a little while (about 5 minutes in my tests), and as soon as you
type "Ctrl+C" in the second terminal, signal_test will be in "stopped" state.

This line will show on the first terminal:
[1]+  Stopped                 ./signal_test

-- Additional comment from mschmidt@redhat.com on 2007-03-08 11:41 EST --
Created an attachment (id=149583)
a modified testcase


-- Additional comment from jan.kratochvil@redhat.com on 2007-03-23 19:24 EST --
Committed:
[ to RHEL3 ]
* Fri Mar 23 2007 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.3.0.0-1.137
- Never lose any pending signal while attaching - resubmit them (BZ 189607).

Comment 1 RHEL Product and Program Management 2007-07-29 18:13:55 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 RHEL Product and Program Management 2007-07-29 18:15:15 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 5 Andrew Cagney 2007-07-30 19:10:18 UTC
Fix available, new tests added.

Comment 10 errata-xmlrpc 2007-11-15 16:11:53 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0811.html



Note You need to log in before you can comment on or make changes to this bug.