Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233729 - kernel bcm43xx network stack is easily broken by overloading
Summary: kernel bcm43xx network stack is easily broken by overloading
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-24 04:10 UTC by Bernard Johnson
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-22 18:50:14 UTC


Attachments (Terms of Use)
network utilization at point stack falls over (deleted)
2007-03-24 04:10 UTC, Bernard Johnson
no flags Details
ping results to gateway (deleted)
2007-03-24 04:13 UTC, Bernard Johnson
no flags Details
flood ping results to gw (deleted)
2007-03-24 04:14 UTC, Bernard Johnson
no flags Details

Description Bernard Johnson 2007-03-24 04:10:37 UTC
Description of problem:
It appears that the bcm43xx wireless stack can be easily broken by flooding the
network.  Notice also the sometimes long delays on the regular ping.

Version-Release number of selected component (if applicable):
kernel-2.6.20-1.3016.fc7

How reproducible:
Always

Steps to Reproduce:
1. start a 'ping gw' in one windows
2. start a 'ping -f gw' in another window
3. wait for stack to fall over

Comment 1 Bernard Johnson 2007-03-24 04:10:37 UTC
Created attachment 150818 [details]
network utilization at point stack falls over

Comment 2 Bernard Johnson 2007-03-24 04:13:54 UTC
Created attachment 150819 [details]
ping results to gateway

Comment 3 Bernard Johnson 2007-03-24 04:14:44 UTC
Created attachment 150820 [details]
flood ping results to gw

Comment 4 Bernard Johnson 2007-03-24 04:19:36 UTC
Also forgot to mention...  Reselecting the access point with NetworkManager
causes a re-association to the wireless gateway and everything seems to be back
to normal.

John L, I'm changing the assignment to you as I suspect you want this bug.  If
not, please reassign.

Comment 5 Bernard Johnson 2007-03-24 04:47:55 UTC
I also tried this with the kernel-2.6.20-1.2925.6.1.fc6.jwltest.29 kernel.  It
is more stable (less network delays and more consistent network saturation) but
in the end it falls over as well.

It appears to be 100% repeatable.

Comment 6 John W. Linville 2007-05-18 18:23:31 UTC
How is performance with the current rawhide kernels?

Comment 7 Bernard Johnson 2007-05-22 18:47:01 UTC
There are still some anomolies as far as the saturation and ping times, but with
kernel-2.6.21-1.3175.fc7 I was not able to make it fall over.  I did have to
update my firmware for the newer kernel too.

I can't verify if the anomolies are because of changes in the wireless signal or
not, so I would consider this resolved.

Comment 8 John W. Linville 2007-05-22 18:50:14 UTC
Cool...thanks for the info!


Note You need to log in before you can comment on or make changes to this bug.