Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233727 - Blank screen on ATI/Radeon: missing MonitorLayout option
Summary: Blank screen on ATI/Radeon: missing MonitorLayout option
Keywords:
Status: CLOSED DUPLICATE of bug 231359
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-24 03:19 UTC by Keith G. Robertson-Turner
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-02 21:51:14 UTC


Attachments (Terms of Use)

Description Keith G. Robertson-Turner 2007-03-24 03:19:14 UTC
Description of problem:
On certain ATI chipsets (e.g. X700) using LCD/Laptop displays, the Radeon driver
requires the extra option:

 Option      "MonitorLayout" "LVDS,AUTO"

Otherwise the primary display remains blank, and this obviously makes installing
Fedora impossible unless textmode is used, or the vesa driver is forced.

Version-Release number of selected component (if applicable):
0.3.32

How reproducible:
Always.

Steps to Reproduce:
1.Boot from FC7t2 Live/Install CD, on system with ATI graphics and an LCD
display as the primary display.
2.
3.
  
Actual results:
Blank screen.

Expected results:
Primary display should be activated and visible.

Additional info:
This is now an old and persistent problem, going back as far as FC5 IIRC, so I'm
surprised it has never been addressed before. Casual inspection shows a few
related bugs here, but nothing that nails the issue with the above option line
(which is well documanted in various other places).

It would be nice to have this special case patched to enable ATI/Laptop users to
install in graphical mode, in time for the final release of FC7.

Not sure if this should be passed upstream to Xorg, is this a bug or a "feature"?

Comment 1 Adam Jackson 2007-03-26 19:37:31 UTC
It's really an ati driver bug.  The problem is we _should_ be getting a
connector table from the BIOS, but we're parsing it wrong, and therefore think
that there's no LVDS hooked up.

I suspect we should just force to LVDS,AUTO if we're on a laptop chip and we
detect NONE,NONE (which is the usual symptom).

Comment 2 Keith G. Robertson-Turner 2007-03-27 00:51:19 UTC
Version-Release number of selected component (if applicable):
radeon 1.25.0 20060524 (kernel-2.6.20-1.2949.fc7)

Comment 3 Adam Jackson 2007-04-02 21:51:14 UTC

*** This bug has been marked as a duplicate of 231359 ***


Note You need to log in before you can comment on or make changes to this bug.