Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233726 - alsa-lib-1.0.14-0.1.rc1.fc6 breaks xine/mplayer sound
Summary: alsa-lib-1.0.14-0.1.rc1.fc6 breaks xine/mplayer sound
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-soundcard
Version: 6
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2007-03-24 03:10 UTC by Bradley
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2007-05-17 09:17:38 UTC

Attachments (Terms of Use)
system-config-soundcard log with 1.0.13 (deleted)
2007-03-24 03:10 UTC, Bradley
no flags Details
system-config-soundcard output with 1.0.14 (deleted)
2007-03-24 03:12 UTC, Bradley
no flags Details

Description Bradley 2007-03-24 03:10:28 UTC
Description of problem:

Upgrading alsa to alsa-lib-1.0.14-0.1.rc1.fc6 breaks xine/mplayer sound.

system-config-soundcard's tests works fine, but mplayer/xine are silent.

I tried both the new kernel is today's updates (kernel-2.6.20-1.2933.fc6, vs the
previous kernel-2.6.20-1.2925.fc6) and the kernel makes no difference

Version-Release number of selected component (if applicable):

alsa-lib-1.0.14-0.1.rc1.fc6 fails
alsa-lib-1.0.13-1.fc6 is fine



How reproducible:

xine <some file>

Steps to Reproduce:
1. Upgrade to ltest errata release of alsa-libs
2. use xine or mplayer to play a file - I'm using lca2006 .oggs, but it appears
to be any file
3. Hear no sound
Actual results:

No sound

Expected results:


Additional info:

Downgrading to alsa-libs 1.0.13 fixes this. I'll attach system-config-soundcard
logs for both versions

Comment 1 Bradley 2007-03-24 03:10:29 UTC
Created attachment 150816 [details]
system-config-soundcard log with 1.0.13

Comment 2 Bradley 2007-03-24 03:12:14 UTC
Created attachment 150817 [details]
system-config-soundcard output with 1.0.14

Comment 3 Anthony Messina 2007-03-24 08:05:27 UTC
I can verify that snd-hda-intel no longer works, though it does get loaded. 
Output from aplay -l:

**** List of PLAYBACK Hardware Devices ****
ALSA lib control.c:910:(snd_ctl_open_noupdate) Invalid CTL hw:0
aplay: device_list:213: control open (0): No such file or directory

system-config-soundcard does create the required /etc/asound.conf file, to no avail.

It worked perfectly in the previous fc6 rpm.

Comment 4 Martin Stransky 2007-03-26 09:34:37 UTC
Can you please check packages from devel? (alsa-lib-1.0.14rc3 and


Comment 5 Martin Stransky 2007-03-26 09:42:48 UTC
Hm, works fine for you use IEC958?

Comment 6 Bradley 2007-03-26 09:52:48 UTC
I'm not sure what that is ;) but I tried system-config-soundcard with both
settings for the second tab ('default PCM define'), didn't make a difference
that I can see.

The devel alsa stuff didn't help either - the test sound is fine, xine fails.

Comment 7 Martin Stransky 2007-03-26 10:54:03 UTC
defaults.pcm.device must be 0 (the first one, in /etc/asound.conf), 4 is a
digital optical output (IEC958).

Please check packages from devel.

Comment 8 Bradley 2007-03-26 11:23:00 UTC
The following /etc/asound.conf works with 1.0.13:

#Generated by system-config-soundcard, do not edit by hand
#DEV 4
defaults.pcm.card 0 
defaults.pcm.device 4 
defaults.ctl.card 0 

It doesn't work with devel (1.0.14-0.3.rc3; .rc2 for alsa-utils). It does work
if I ignore the command and manually change defaults.pcm.device to 0. After that
change it also works with alsa* from fc6-updates.

Comment 9 Aaron Gaudio 2007-04-02 17:25:51 UTC
Indeed, I get the same problem. I've got an Intel ICH7 sound card. When I
upgrade to the 1.0.14 alsa-lib, sound stops working, not just for xine and
mplayer, but for everything (flash-plugin, sox, aplay, etc.).

I found that the only thing that works in this case, strangely enough, is to use
-ao oss for mplayer. This passes through to the OSS emulation in alsa, and
appears to work. Mplayer with oss was the only thing that could play sound
though (none of the other normal oss apps that use /dev/dsp did).

Downgrading to 1.0.13 restores all my sounds. I don't have my soundcard set to
use IEC958, just "Intel ICH7".

Comment 10 Aaron Gaudio 2007-04-02 17:46:01 UTC
Looks like I spoke too soon. My device actually *was* set to use IEC958 (on the
2nd tab). I changed it to just Intel ICH7, and it didn't work at first (testing
with mplayer). Then I checked the "Disable specific card configuration" and it
worked. When I unchecked it, it still worked. Whaddya know. My /etc/asound.conf
looked like Bradley's before, now it looks like this:

#Generated by system-config-soundcard, do not edit by hand
#DEV 0
defaults.pcm.card 0 
defaults.pcm.device 0 
defaults.ctl.card 0 

Comment 11 Martin Stransky 2007-04-10 11:48:29 UTC
okay, closing...

Comment 12 Bradley 2007-04-10 13:45:12 UTC
Err, no. It worked, then it stopped, so its a bug.

I shouldn't have to hand edit config files (especially ones that say 'do not
edit by hand') to restore functionality that was broken as part of an fc6 update.

Comment 13 Martin Stransky 2007-05-16 12:28:50 UTC
I can't reproduce it here. So if you want me to fix it, please downgrade to
1.0.13, create a log (root/scsconfig.log) and attach it here. Then try to update
to 1.0.14 and check the log again. The /etc/modprobe.conf should be the same...

Comment 14 Bradley 2007-05-16 14:21:09 UTC
I attached both scsconfig files when the bug was created - see attachment 150816 [details]
(1.0.13) and attachment 150817 [details] (1.0.14)

Comment 15 Martin Stransky 2007-05-16 14:27:32 UTC
Aha. I really don't know why 1.0.13 works with this /etc/modprobe.conf:

------- /etc/asound.conf --------
#Generated by system-config-soundcard, do not edit by hand
#DEV 4
defaults.pcm.card 0 
defaults.pcm.device 4 
defaults.ctl.card 0 

This configuration isn't correct.

If 1.0.13 works with a broken config, it's a bug in 1.0.13, not in 1.0.14.

Closing as not a bug.

Comment 16 Bradley 2007-05-16 22:46:21 UTC
system-config-soundcard generated that, so then its a bug in that

Comment 17 Martin Stransky 2007-05-17 09:17:38 UTC
system-config-soundcard generates what the user tells it. I've checked it and
works fine. There was a problem with savig the current configuration in
system-config-soundcard, but it's fixed in FC7 now. Closing again. If you think
there's a bug, please write steps how to reproduce it and/or attach a patch for it.

Note You need to log in before you can comment on or make changes to this bug.