Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233711 - Tape test fails with AttributeError
Summary: Tape test fails with AttributeError
Keywords:
Status: CLOSED DUPLICATE of bug 233710
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-23 22:07 UTC by Keith Orsak
Modified: 2008-07-16 21:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-23 22:14:24 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Keith Orsak 2007-03-23 22:07:32 UTC
Description of problem:

When running a tape test the test always fails because of an AttributeError.  
Here is the output that I receive while running the test:

Tape test is running, please be patient ... 
...finished running ./tape.sh, exit code=0
recovered exit code=0
rhts-report-result /HTS/hts/tape PASS /var/log/hts/runs/1/tape/output.log 
saveOutput: /var/log/hts/runs/1/tape/output.log
Return value was 0
Traceback (most recent call last):
  File "/usr/bin/hts", line 113, in ?
    success = hts.do(args)
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 67, in do
    return self.doCertify()
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 260, in 
doCertify
    if test.isDisabled():
AttributeError: 'list' object has no attribute 'isDisabled'

Version-Release number of selected component: HTS-5.0-31


How reproducible:  This error has occurred on every tape test that I have run 
on three different servers ((1)IA64, (2)i386) for three different tape drives.

Steps to Reproduce:

1.  Disable the firewall in Red Hat 5.
2.  Enable SELinux targeting policy with Enforcing on.
3.  Turn off the server and plug in the tape drive.
4.  Reboot the computer.
3.  Open a terminal and start server (root->hts server start)
4.  Create test plan (root>hts plan)  
5.  Run the tape test (root>hts certify --test=tape)

Actual results:

Tape test is running, please be patient ... 
...finished running ./tape.sh, exit code=0
recovered exit code=0
rhts-report-result /HTS/hts/tape PASS /var/log/hts/runs/1/tape/output.log 
saveOutput: /var/log/hts/runs/1/tape/output.log
Return value was 0
Traceback (most recent call last):
  File "/usr/bin/hts", line 113, in ?
    success = hts.do(args)
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 67, in do
    return self.doCertify()
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 260, in 
doCertify
    if test.isDisabled():
AttributeError: 'list' object has no attribute 'isDisabled'

Expected results:


Additional info:

Comment 1 Keith Orsak 2007-03-23 22:14:24 UTC

*** This bug has been marked as a duplicate of 233710 ***


Note You need to log in before you can comment on or make changes to this bug.