Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233702 - ElectricFence doesn't support EF_DISABLE_BANNER
Summary: ElectricFence doesn't support EF_DISABLE_BANNER
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ElectricFence
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Machata
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-23 21:11 UTC by Linus Torvalds
Modified: 2015-05-05 01:33 UTC (History)
1 user (show)

Fixed In Version: FC-6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-02 20:47:55 UTC


Attachments (Terms of Use)

Description Linus Torvalds 2007-03-23 21:11:43 UTC
Description of problem:

 Fedora Core 6 contains an rpm called "ElectricFence-2.2.2", but it seems
 to be some strange version that doesn't support disabling the banner that
 EF prints out on startup to stderr.

 Since a lot of test-suites (the git test-suite in particular, but that's
 not anything odd) test that stderr looks a certain way, this makes it useless
 for any such situation, since linking with efence will break the test suite.

 For something that is supposed to help debugging, breaking test-suites is a
 really stupid idea.

Version-Release number of selected component (if applicable):

 It claims to be ElectricFence-2.2.2, but at least the original EF has
 supported EF_DISABLE_BANNER for a looong time, and ElectricFence 2.1.18
 in Debian apparently gets this right. 

How reproducible:

 Totally. Just link a program with ElectricFence using -lefence, and try to
 run it. It outputs a really annoying copyright message to stderr, and you
 cannot disable it with EF_DISABLE_BANNER the way it's supposed to.

Steps to Reproduce:
1. Compile with efence
2. Run with EF_DISABLE_BANNER=1
3. No Profit!
  
Actual results:

 Electric Fence 2.2.0 Copyright (C) 1987-1999 Bruce Perens <bruce@perens.com>

Expected results:

 sweet silence

Additional info:

 Googling for EF_DISABLE_BANNER shows that it existed in 2.1.13. Either it
 got incorrectly dropped, or (more likely) the Fedora package is actually
 based on some really old version, despite calling itself 2.2.2.

Comment 1 Petr Machata 2007-03-28 18:37:13 UTC
Fixed in rawhide & FC-6.

Comment 2 Linus Torvalds 2007-03-30 19:07:55 UTC
I've gotten the new ElectricFence through yum, and the bug is not fixed.

A "rpm -q ElectricFence" reports

   ElectricFence-2.2.2-21.fc6

And it still prints out that irritating

  Electric Fence 2.2.0 Copyright (C) 1987-1999 Bruce Perens <bruce@perens.com>

warning on stderr, and there *still* isn't any way to disable it:

        export EF_DISABLE_BANNER=1

does nothing. In fact, I don't think it *can* do anything:

        strings - /usr/lib64/libefence* | sort -u | grep EF_

does not show EF_DISABLE_BANNER anywhere. So nothing seems to
have changed.


Comment 3 Petr Machata 2007-04-02 02:26:41 UTC
I forgot to actually apply the patch when transferring it from devel to FC-6. 
Package built and submitted for pushing.

Comment 4 Fedora Update System 2007-04-02 16:22:23 UTC
ElectricFence-2.2.2-22.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 5 Linus Torvalds 2007-04-02 20:47:55 UTC
Thanks, "yum upgrade" got it now, and I can verify that it's fixed.

I closed it.


Note You need to log in before you can comment on or make changes to this bug.