Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233692 - hplip hp-sendfax PyQt combination is broken
Summary: hplip hp-sendfax PyQt combination is broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 6
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Update
TreeView+ depends on / blocked
 
Reported: 2007-03-23 19:50 UTC by Bernard Johnson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 1.7.2-3.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 501834 (view as bug list)
Environment:
Last Closed: 2007-04-19 08:26:24 UTC


Attachments (Terms of Use)

Description Bernard Johnson 2007-03-23 19:50:39 UTC
Description of problem:
When I add any file to the list of fax pages using hp-sendfax, the process
hangs.  The activity bar keeps moving, but the last thing seen in the log is:

hp-sendfax[2312]: debug: 'msg=DeviceCloseResult\nresult-code=0\n'
hp-sendfax[2312]: debug: text/plain
hp-sendfax[2312]: debug: text/plain
hp-sendfax[2312]: debug: Adding file: title='/tmp/myfile.txt'
file=/tmp/myfile.txt mime_type=text/plain mime_desc=Plain Text)
hp-sendfax[2312]: debug: Printer state = 3
hp-sendfax[2312]: debug: Job ID=18
(hangs indefinately)

I have tried multiple files and file types with the same results.  There are not
permission problems with the files and they are not corrupt.

The print jobs in the printer status shows "printing" for about 20 seconds or so
and the "completed".

I have also tried restarting the CUPS fax printer.

SELinux is not enabled.

Version-Release number of selected component (if applicable):
hplip-1.6.12-1.fc6

How reproducible:
Always

Comment 1 Bernard Johnson 2007-03-23 22:46:02 UTC
hp-sendfax also consumes 90%+ cpu when running, even when idle.

It seems that this bug is probably the same as: 

https://launchpad.net/ubuntu/+source/python-qt3/+bug/66830


Options:
1) downgrade PyQt to 3.14 (that was inconclusive in the ubuntu thread)
2) upgrade to hplip 1.7.1

Comment 2 Bernard Johnson 2007-03-23 23:02:40 UTC
Another ref:
http://permalink.gmane.org/gmane.comp.printing.hplip.devel/247

Comment 3 Bernard Johnson 2007-03-28 21:25:27 UTC
So, here is what I know so far.

I tried many different combinations of PyQT and hplip from FC-5/FC-6/FC-6
updates with no luck.  I did not try PyQT < 3.15 since it seems that downgrading
is ultimately not the right direction.

I was able to build hplip 1.7.3 and the problem goes away.

I still get an error in 1.7.3 but it's totally unrelated, and I've already dug
through the code and verified an upstream bug (and it only happens if you're low
on toner so it's minor).

I would suggest an upgrade to 1.7.3.  If you have other combinations or such
that you'd like me to test for you, let me know and I'll give them a try.

Comment 4 Bernard Johnson 2007-04-14 07:49:21 UTC
Verified working hplip-1.7.2-2.fc6 in updates-testing.

Comment 5 Tim Waugh 2007-04-16 09:07:28 UTC
Great, thanks for testing.

Comment 6 Fedora Update System 2007-04-18 22:35:14 UTC
Fixed in update: hplip-1.7.2-3.fc6


Note You need to log in before you can comment on or make changes to this bug.