Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233690 - login fails - .xsession-errors: localuser: being added to access control list
Summary: login fails - .xsession-errors: localuser: being added to access control list
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-23 19:36 UTC by Mads Villadsen
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-23 21:02:29 UTC


Attachments (Terms of Use)

Description Mads Villadsen 2007-03-23 19:36:17 UTC
Description of problem:
I am running F7T2.

After a yum update today I can no longer login. X starts fine and gdm runs, but
when I login I very qucikly get the message that my login session lasted less
than 10 seconds. The details just say:

localuser: being added to access control list

I have tried login using gdm, xdm and just by running startx - they all fail
with the same message. I have changed selinux to permissive, but that didn't
help either.

This is on a dell laptop with an intel 945GM graphics card. I have tried using
both the i810 driver and the intel driver. No difference.

Version-Release number of selected component (if applicable):
xorg-x11-apps-7.1-4.fc7
xorg-x11-drivers-7.2-5.fc7
xorg-x11-drv-acecad-1.1.0-3.fc7
xorg-x11-drv-aiptek-1.0.1-3.fc7
xorg-x11-drv-amd-0.0-8.20061016git.fc7
xorg-x11-drv-apm-1.1.1-3.fc7
xorg-x11-drv-ark-0.6.0-3.fc7
xorg-x11-drv-ast-0.81.0-4.fc7
xorg-x11-drv-ati-6.6.3-2.fc7
xorg-x11-drv-calcomp-1.1.0-2.fc7
xorg-x11-drv-chips-1.1.1-3.fc7
xorg-x11-drv-cirrus-1.1.0-3.fc7
xorg-x11-drv-citron-2.2.0-2.fc7
xorg-x11-drv-cyrix-1.1.0-4
xorg-x11-drv-digitaledge-1.1.0-2.fc7
xorg-x11-drv-dmc-1.1.0-3.fc7
xorg-x11-drv-dummy-0.2.0-3.fc7
xorg-x11-drv-dynapro-1.1.0-3.fc7
xorg-x11-drv-elo2300-1.1.0-2.fc7
xorg-x11-drv-elographics-1.1.0-2.fc7
xorg-x11-drv-evdev-1.1.2-3.fc7
xorg-x11-drv-fbdev-0.3.1-2.fc7
xorg-x11-drv-fpit-1.1.0-2.fc7
xorg-x11-drv-glint-1.1.1-5.fc7
xorg-x11-drv-hyperpen-1.1.0-3.fc7
xorg-x11-drv-i128-1.2.0-5.fc7
xorg-x11-drv-i740-1.1.0-3.fc7
xorg-x11-drv-i810-1.6.5-14.fc7
xorg-x11-drv-jamstudio-1.1.0-2.fc7
xorg-x11-drv-joystick-1.1.0-2.fc7
xorg-x11-drv-keyboard-1.1.0-3.fc7
xorg-x11-drv-magellan-1.1.0-2.fc7
xorg-x11-drv-magictouch-1.0.0.5-3.fc7
xorg-x11-drv-mga-1.4.6.1-3.fc7
xorg-x11-drv-microtouch-1.1.0-2.fc7
xorg-x11-drv-mouse-1.2.1-2.fc7
xorg-x11-drv-mutouch-1.1.0-3.fc7
xorg-x11-drv-neomagic-1.1.1-2.1
xorg-x11-drv-nsc-2.8.1-3.fc7
xorg-x11-drv-nv-2.0.0-2.fc7
xorg-x11-drv-palmax-1.1.0-2.fc7
xorg-x11-drv-penmount-1.1.0-3.fc7
xorg-x11-drv-rendition-4.1.3-2.fc7
xorg-x11-drv-s3-0.5.0-3.fc7
xorg-x11-drv-s3virge-1.9.1-3.fc7
xorg-x11-drv-savage-2.1.2-3.fc7
xorg-x11-drv-siliconmotion-1.5.1-1.fc7
xorg-x11-drv-sis-0.9.3-2.fc7
xorg-x11-drv-sisusb-0.8.1-5.fc7
xorg-x11-drv-spaceorb-1.1.0-2.fc7
xorg-x11-drv-summa-1.1.0-2.fc7
xorg-x11-drv-tdfx-1.3.0-4.fc7
xorg-x11-drv-tek4957-1.1.0-2.fc7
xorg-x11-drv-trident-1.2.3-4.fc7
xorg-x11-drv-tseng-1.1.0-4.fc7
xorg-x11-drv-ur98-1.1.0-2.fc7
xorg-x11-drv-v4l-0.1.1-5.fc7
xorg-x11-drv-vesa-1.3.0-5.fc7
xorg-x11-drv-vga-4.1.0-3.fc7
xorg-x11-drv-via-0.2.2-1.fc7
xorg-x11-drv-vmmouse-12.4.0-2.1
xorg-x11-drv-vmware-10.14.1-1.fc7
xorg-x11-drv-void-1.1.0-4.fc7
xorg-x11-drv-voodoo-1.1.0-4.fc7
xorg-x11-filesystem-7.1-2.fc6
xorg-x11-fonts-ISO8859-1-75dpi-7.1-3.fc7
xorg-x11-font-utils-7.1-2
xorg-x11-proto-devel-7.2-6.fc7
xorg-x11-server-utils-7.2-1.fc7
xorg-x11-server-Xorg-1.2.99.902-1.fc7
xorg-x11-xauth-1.0.2-1.fc7
xorg-x11-xfs-1.0.2-3.1
xorg-x11-xinit-1.0.2-15.fc7
xorg-x11-xkb-utils-1.0.2-3.fc7


How reproducible:
Always.

Steps to Reproduce:
1. login
2. get error

Comment 1 Will Woods 2007-03-23 19:44:09 UTC
I have the same problem on my i915 and i945-based machines. Other systems appear
to be unaffected.

All gdb tells me is that Xorg gets a SIGPIPE and then decides to die.

There's no obvious errors in Xorg.0.log - the problem happens shortly after
AIGLX gives its 'Loaded and initialized /usr/lib/dri/i915_dri.so' message. No
SELinux audit messages are found. I'm fairly well stumped on how to debug this
further.

Comment 2 Adam Jackson 2007-03-23 19:47:56 UTC
SIGPIPE is just the signal we get when clients disconnect.  it's completely normal.

The way to determine if this is X's fault is to boot to runlevel 3 and run 'X
:0' from the console by itself.  if X comes up, then it's probably not a bug in
X, but rather, some client being started as part of the X session is failing,
and therefore the startup script just aborts.

Attaching /var/log/Xorg.0.log would help, but it's likely to just tell us that
the server starts correctly and it's actually the session that fails.

Comment 3 Will Woods 2007-03-23 19:50:36 UTC
"X :0" in runlevel 3 works OK, so I'm also thinking it's the session. I'm still
puzzled as to why this only happens on intel/i810 chipset machines, though.

Comment 4 Mads Villadsen 2007-03-23 20:27:03 UTC
It doesn't seem to be directly tied to the new version of the i810 driver. I
found a mirro that had yet to be updated and havne now installed
xorg-x11-drv-i810-1.6.5-13.fc7 and the error still occurs.

I also tried booting with the oldest kernel I have (2.6.20-1.2987) to see if
that made a difference, but it did not.

I installed some update yesterday and today I booted, logged in and installed
more updates. So logically I guess it has to be an update from today that did it
- however I can't find a likely suspect among the following (output from rpm -qa
--last):

xorg-x11-drv-i810-1.6.5-13.fc7                Fri 23 Mar 2007 09:08:34 PM CET
gocr-0.44-2.fc7                               Fri 23 Mar 2007 05:52:18 PM CET
NetworkManager-vpnc-0.6.4-3.fc7               Fri 23 Mar 2007 05:52:03 PM CET
elinks-0.11.1-5.1                             Fri 23 Mar 2007 03:55:30 PM CET
anaconda-11.2.0.40-1                          Fri 23 Mar 2007 02:43:27 PM CET
redhat-artwork-5.0.12-1.fc7                   Fri 23 Mar 2007 02:43:12 PM CET
fedora-logos-6.0.97-1.fc7                     Fri 23 Mar 2007 02:42:12 PM CET
kernel-2.6.20-1.3016.fc7                      Fri 23 Mar 2007 02:41:50 PM CET
kernel-headers-2.6.20-1.3016.fc7              Fri 23 Mar 2007 02:41:38 PM CET
fedora-release-notes-6.92-3                   Fri 23 Mar 2007 02:41:25 PM CET
yum-updatesd-3.1.5-1.fc7                      Fri 23 Mar 2007 02:41:23 PM CET
selinux-policy-targeted-2.5.9-5.fc7           Fri 23 Mar 2007 02:41:14 PM CET
selinux-policy-2.5.9-5.fc7                    Fri 23 Mar 2007 02:41:09 PM CET
yum-3.1.5-1.fc7                               Fri 23 Mar 2007 02:41:04 PM CET
inkscape-0.45.1-1.fc7                         Thu 22 Mar 2007 06:31:50 PM CET
firstboot-1.4.34-1.fc7                        Thu 22 Mar 2007 05:04:30 PM CET
fedora-release-6.92-1                         Thu 22 Mar 2007 05:04:29 PM CET
kernel-2.6.20-1.3003.fc7                      Thu 22 Mar 2007 05:03:59 PM CET
firstboot-tui-1.4.34-1.fc7                    Thu 22 Mar 2007 05:03:51 PM CET


Comment 5 Mads Villadsen 2007-03-23 20:33:38 UTC
I have also tried adding a new session to gdm which only runs xterm - but the
login process dies just as fast with the same error.

Comment 6 Will Woods 2007-03-23 21:02:29 UTC
Ah! This is apparently actually a problem with anaconda interfering with the X
server session startup. It should be fixed in tomorrow's rawhide. See the
following mail:

https://www.redhat.com/archives/fedora-test-list/2007-March/msg00476.html


Note You need to log in before you can comment on or make changes to this bug.