Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233689 - g-p-m modal error dialogs hide behind prefs dialog
Summary: g-p-m modal error dialogs hide behind prefs dialog
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-power-manager
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-23 19:34 UTC by Paul W. Frields
Modified: 2013-03-06 03:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-14 09:06:23 UTC


Attachments (Terms of Use)

Description Paul W. Frields 2007-03-23 19:34:59 UTC
Description of problem:
If there is a hal/udev error, the modal dialogs that appear with the error
messages are hidden behind the preferences dialog.  The two affected dialogs
have the following error messages: (1) "HAL does not support power management!"
(2) "Either HAL or DBUS are not working!"

Version-Release number of selected component (if applicable):
2.18.0-1.fc7

How reproducible:
Every time

Steps to Reproduce:
1. Right-click g-p-m trayicon
2. Choose Preferences
3. Prefs dialog appears but is unusable due to hidden modals.  Sweep prefs aside
to see modals.
  
Actual results:


Expected results:


Additional info:

Comment 1 Richard Hughes 2007-03-23 19:50:00 UTC
Agree, this sucks. This is fixed in head, but I'll backport to 2-18.

Comment 2 David Zeuthen 2007-03-23 19:59:50 UTC
IMO these dialogs just needs to be deleted.

Comment 3 Richard Hughes 2007-03-23 20:20:39 UTC
Yes, that's what I did.

Comment 4 David Zeuthen 2007-03-23 20:30:17 UTC
Oh, you ripped out the dialogs from CVS HEAD? Sweet!

Comment 5 Richard Hughes 2007-05-14 09:06:23 UTC
Yep. closing upstream. If HAL isn't running when the system is started, then 99%
of g-p-m does not work and so we just exit. Some people just want to run the
system without HAL...


Note You need to log in before you can comment on or make changes to this bug.