Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233687 - ia64: gail's atk_version must be 1.8.0
Summary: ia64: gail's atk_version must be 1.8.0
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gail
Version: rawhide
Hardware: ia64
OS: Linux
high
high
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: fedora-ia64
TreeView+ depends on / blocked
 
Reported: 2007-03-23 19:26 UTC by Prarit Bhargava
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-23 21:20:18 UTC


Attachments (Terms of Use)

Description Prarit Bhargava 2007-03-23 19:26:59 UTC
From a private email from Tim Yanmin:

GNOME seems to be (still) broken -- only now
everything except gdm does work. I think this is still related to the
bug I reported upstream a while back (see
http://bugzilla.gnome.org/show_bug.cgi?id=410636).

Manually compiling gail 1.18 (make sure atk 1.18, not 1.17 is
installed) fixes this. So I'm guessing the gail RPM build must be
dodgy because it was compiled against the older atk with the bug. The
SRPM has this line:

%define atk_version 1.7.0

For ia64 to work properly this should be 1.8.0 where upstream have
fixed the bug -- the bug which is a header typo causes a compiler
warning (not an error) and only seems to really be a problem on IA64;
it does not appear on other architectures or I'm guessing this would
have been fixed a while ago.

Matthias, would it be possible to get a change in only for ia64 such that we 

%define atk_version 1.8.0 ?

That way we wouldn't effect the mainline arches ...

Comment 1 Prarit Bhargava 2007-03-23 19:30:24 UTC
Uh ... s/Yanmin/Yamin/g

:)

P.

Comment 2 Matthias Clasen 2007-03-23 21:12:53 UTC
Changing that define won't really do much per se; if things are as they appear
to be, simply rebuilding gail against 1.8.0 should fix things. Of course,
bumping the
minimal version can be done at the same time...

Comment 3 Matthias Clasen 2007-03-23 21:19:40 UTC
Done in gail-1.18.0-2.fc7

Comment 4 Tim Yamin 2007-03-30 16:05:28 UTC
Confirmed fixed -- thanks!


Note You need to log in before you can comment on or make changes to this bug.