Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233683 - Traceback occurred while packaging dvdrw test results
Summary: Traceback occurred while packaging dvdrw test results
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness)
Version: 5
Hardware: ia64
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-23 19:09 UTC by Rick Hester
Modified: 2007-03-23 22:49 UTC (History)
1 user (show)

Fixed In Version: hts-5.0-32
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-23 22:49:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
console output of traceback and test plan summary (deleted)
2007-03-23 19:09 UTC, Rick Hester
no flags Details

Description Rick Hester 2007-03-23 19:09:00 UTC
Description of problem:
After completing  a test of the DVD+RW device, executed the 
hts submit function to package the test results.  This
resulted in a trace back.   See attached console output

Version-Release number of selected component (if applicable):
hts-5.0-31

How reproducible:

Have been able to get the traceback on two of two tries to package
results


Steps to Reproduce:
1. run test on dvd+-rw device (hts certify --test cdrom
2. at completion of test, package results - hts submit
3. traceback occurs during packaging of the results
  
Actual results:
copying attachments...
Traceback (most recent call last):
  File "/usr/bin/hts", line 113, in ?
    success = hts.do(args)
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 73, in do
    return self.doSubmit()
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 370, in doSubmit
    if report.WriteResultsRPM(self.LogDirectory):
  File "/usr/lib/python2.4/site-packages/hts/report.py", line 192, in
WriteResultsRPM
    self.WriteLogForRPM(testsByName[testName], runNumber, byTestDirectory)
  File "/usr/lib/python2.4/site-packages/hts/report.py", line 244, in WriteLogForRPM
    log.write(outputLog)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xb1' in position
30285: ordinal not in range(128)


Expected results:
results packaged.

Additional info:

Comment 1 Rick Hester 2007-03-23 19:09:02 UTC
Created attachment 150788 [details]
console output  of traceback and test plan summary

Comment 2 Rick Hester 2007-03-23 19:15:29 UTC
Bumping the severity of this up a little, since I have test results that 
I can not package (and submit) because of this problem.

Comment 3 Irina Boverman 2007-03-23 20:06:29 UTC
Can you please try hts .32? It has been posted on partner's site, and a similar
problem was corrected there.

Comment 4 Rick Hester 2007-03-23 22:38:06 UTC
I will download that now.

Do I need to re-run the test or can I just use .32 to
package the existing results?

Comment 5 Rick Hester 2007-03-23 22:49:30 UTC
that fixed the problem.   

Closing the defect.


Note You need to log in before you can comment on or make changes to this bug.