Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233679 - hplip hp-toolbox sends wrong options to hp-sendfax
Summary: hplip hp-toolbox sends wrong options to hp-sendfax
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-23 18:55 UTC by Bernard Johnson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-24 19:06:45 UTC


Attachments (Terms of Use)

Description Bernard Johnson 2007-03-23 18:55:59 UTC
Description of problem:
hp-toolbox uses --standalone option when starting hp-sendfax.  This is not a
valid option for hp-sendfax.

Version-Release number of selected component (if applicable):
hplip-1.6.12-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. run hp-toolbox
2. run
3.
  
Actual results:
$ /usr/share/hplip/toolbox 

HP Linux Imaging and Printing System (ver. 1.6.12)
HP Device Manager ver. 6.3

Copyright (c) 2003-6 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: option --standalone not recognized

Expected results:


Additional info:

$ hp-sendfax --help

HP Linux Imaging and Printing System (ver. 1.6.12)
PC Sendfax Utility ver. 4.4

Copyright (c) 2003-6 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Allows for sending faxes from the PC using HPLIP supported multifunction printers.

Usage: hp-sendfax [PRINTER|DEVICE-URI] [OPTIONS] [MODE] [FILES]

[PRINTER|DEVICE-URI] (See Notes)
  To specify a        -d<device-uri> or --device=<device-uri>               
  device-URI:                                                               
  To specify a CUPS   -p<printer> or --printer=<printer>                    
  printer:                                                                  

[MODE]
  Enter graphical UI  -u or --gui (Default)                                 
  mode:                                                                     
  Run in              -n or --non-interactive                               
  non-interactive                                                           
  mode (batch mode):                                                        

[OPTIONS]
  Specify the fax     -f<number(s)> or --faxnum=<number(s)> (-n only)       
  number(s):                                                                
  Specify the         -r<recipient(s)> or --recipient=<recipient(s)> (-n    
  recipient(s):       only)                                                 
  Specify the         -g<group(s)> or --group=<group(s)> (-n only)          
  groups(s):                                                                
  Bus to probe (if    -b<bus> or --bus=<bus>                                
  device not                                                                
  specified):                                                               
                      <bus>: cups*, usb*, net, bt, fw, par* (*defaults)     
                      (Note: bt and fw not supported in this release.)      
  Set the logging     -l<level> or --logging=<level>                        
  level:                                                                    
                      <level>: none, info*, error, warn, debug (*default)   
  Run in debug mode:  --gg (same as option: -ldebug)                        
  This help           -h or --help                                          
  information:                                                              

[FILES]
  An optional list                                                          
  of files to add to                                                        
  the fax job.                                                              

Notes:
1. If device or printer is not specified, the local device bus is probed and the
program enters interactive mode.
2. If -p* is specified, the default CUPS printer will be used.
3. Coversheets are not supported in non-interactive mode (-n)
4. Fax numbers and/or recipients should be listed in comma separated lists (-n
only).

See Also:
hp-fab

Comment 1 Bernard Johnson 2007-03-24 19:06:45 UTC
I'm closing this as NOTABUG because:

my ~/.hplip.conf contained the "--standalone" option to hp-sendfax, probably
from an earlier version.  Removing the ~/.hplip.conf and running hp-sendfax
results in creating a new ~/.hplip.conf that does not have that option.


Note You need to log in before you can comment on or make changes to this bug.