Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233662 - UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 1: ordinal not in range(128)
Summary: UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 1: ordin...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
: 235063 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-23 17:25 UTC by James Laska
Modified: 2013-09-02 06:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-17 16:01:50 UTC


Attachments (Terms of Use)
anacdump.txt (deleted)
2007-03-23 17:25 UTC, James Laska
no flags Details

Description James Laska 2007-03-23 17:25:39 UTC
Text-mode french install triggers a unicode conversion error:

Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 161, in callback
    s += (hdr['summary'] or "")
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 556, in
runTransaction
    errors = self.ts.run(cb.callback, '')
  File "/usr/lib/anaconda/yuminstall.py", line 526, in _run
    self.runTransaction(cb=cb)
  File "/usr/lib/anaconda/yuminstall.py", line 501, in run
    self._run(instLog, cb, intf)
  File "/usr/lib/anaconda/yuminstall.py", line 1114, in doInstall
    self.ayum.run(self.instLog, cb, anaconda.intf, anaconda.id)
  File "/usr/lib/anaconda/backend.py", line 234, in doInstall
    anaconda.backend.doInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 203, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 602, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 956, in <module>
    anaconda.intf.run(anaconda)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 1: ordinal
not in range(128)

Comment 1 James Laska 2007-03-23 17:25:39 UTC
Created attachment 150776 [details]
anacdump.txt

Comment 2 Chris Lumens 2007-04-03 17:58:02 UTC
*** Bug 235063 has been marked as a duplicate of this bug. ***

Comment 3 Chris Lumens 2007-04-17 16:01:50 UTC
This will be fixed in the next build of anaconda.


Note You need to log in before you can comment on or make changes to this bug.