Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233659 - shorewall-3.2.8-1.fc6 is not compatible with kernel modules included in kernel-2.6.20-1.2925.fc6
Summary: shorewall-3.2.8-1.fc6 is not compatible with kernel modules included in kerne...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: shorewall
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Robert Marcano
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 233987 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-23 17:04 UTC by Mark Moroni
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-26 16:17:09 UTC


Attachments (Terms of Use)

Description Mark Moroni 2007-03-23 17:04:06 UTC
Description of problem:
The current FC6 extras shorewall package: shorewall-3.2.8-1.fc6 is not 
compatible with kernel 2.6.20-1.2925.fc6 or greater.

The /usr/share/shorewall/modules file needs to be updated to take into account 
the name changes on some of the modules that were introduced as part of this 
kernel release.

For example in kernels <= 2.6.19, the modules were named ip_conntrack_ftp, and 
ip_nat_ftp.  With kernels >= 2.6.20 these modules changed to nf_conntrack_ftp 
and nf_nat_ftp.  These were not the only module name changes.  I was able to 
work around this by editing the /usr/share/shorewall/modules file to take into 
account the module name changes.  Without this change, my ftp server was 
failing due to the fact that the modules were not being loaded.

Version-Release number of selected component (if applicable):
shorewall-3.2.8-1.fc6 (with kenrel 2.6.20)

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Robert Marcano 2007-03-23 18:04:11 UTC
ummmm, i am testing the new 3.4.x series for the bug #233258, i will test if
this solves the problem with newer kernels, 

Comment 2 Robert Marcano 2007-03-26 15:21:04 UTC
*** Bug 233987 has been marked as a duplicate of this bug. ***

Comment 3 Robert Marcano 2007-03-26 16:17:09 UTC
Updated waiting to be signed and to be added to the repository


Note You need to log in before you can comment on or make changes to this bug.