Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233633 - Wrong cluster members are displayed in system-config-clusters
Summary: Wrong cluster members are displayed in system-config-clusters
Keywords:
Status: CLOSED DUPLICATE of bug 236014
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-cluster
Version: 5.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-23 15:08 UTC by Robert Hell
Modified: 2009-04-16 22:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-12 20:40:51 UTC


Attachments (Terms of Use)
Screenshot of the problem (deleted)
2007-03-23 15:14 UTC, Robert Hell
no flags Details

Description Robert Hell 2007-03-23 15:08:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.2; WOW64; .NET CLR 2.0.50727; InfoPath.1)

Description of problem:
After having a cluster running the cluster member information in system-config-cluster (Cluster Management tab) is displayed wrong.

Instead of the member name the join-time is displayed and so on ...

Version-Release number of selected component (if applicable):
system-config-cluster-1.0.39-1.0

How reproducible:
Always


Steps to Reproduce:
1. Install a cluster
2. Run system-config-cluster
3.

Actual Results:
see attached screenshot

Expected Results:
correct display of cluster member name, cluster votes, cluster state

Additional info:
Seems to be a bug while parsing the output of /sbin/cman_tool nodes in CommandHandler.py:
/sbin/cman_tool nodes
Node  Sts   Inc   Joined               Name
   1   M      4   2007-03-22 13:22:39  pg-hba-001
   2   M     24   2007-03-23 11:03:17  pg-hba-002

Comment 1 Robert Hell 2007-03-23 15:14:11 UTC
Created attachment 150765 [details]
Screenshot of the problem

Comment 2 Jim Parsons 2007-03-23 15:40:35 UTC
Yuk. Sorry - still getting used to new cman_tool syntax. There will be an async
errata release for s-c-cluster very soon - I would strongly suspect that a fix
for this will be in there :)

Do you want a quick patched version of the app that fixes this issue (that is,
not officially released yet)? If this will help, I'll move this to the top of
the list and post it here...just say the word.

Comment 3 Robert Hell 2007-03-23 15:46:57 UTC
No thanks, no problem at all. I'll be waiting for the errata.


Comment 4 Robert Hell 2007-03-28 08:19:44 UTC
I have another problem with s-c-cluster - because it's similar to the reported 
in this bugzilla and concerns the same source file (CommandHandler.py), i'm not 
creating a new bugzilla.

After simulating one cluster node dead (by unplugging it from the network) the 
cluster node which is still alive fences the node. After that it's not possible 
to open s-c-cluster on the remaining cluster node:
Traceback (most recent call last):
  File "/usr/sbin/system-config-cluster", line 690, in ?
    runFullGUI()
  File "/usr/sbin/system-config-cluster", line 672, in runFullGUI
    baseapp = basecluster(glade_xml, app)
  File "/usr/sbin/system-config-cluster", line 133, in __init__
    self.mgmttab = MgmtTab(glade_xml, self.model_builder,self.winMain)
  File "/usr/share/system-config-cluster/MgmtTab.py", line 117, in __init__
    self.prep_tree()
  File "/usr/share/system-config-cluster/MgmtTab.py", line 184, in prep_tree
    nodes = self.command_handler.getNodesInfo(self.model_builder.getLockType())
  File "/usr/share/system-config-cluster/CommandHandler.py", line 327, in 
getNodesInfo
    nd = NodeData(words[1],words[3],words[4])
IndexError: list index out of range

Here is some output from the cluster status tools:
[root@pg-ba-001 ~]#  /usr/sbin/clustat 
Member Status: Quorate

  Member Name                        ID   Status
  ------ ----                        ---- ------
  pg-hba-001                            1 Online, Local, rgmanager
  pg-hba-002                            2 Offline

  Service Name         Owner (Last)                   State         
  ------- ----         ----- ------                   -----         
  service:pg-ba-vts1   pg-hba-001                     started         
  service:pg-ba-vts2   (pg-hba-001)                   failed          

[root@pg-ba-001 ~]#  /usr/sbin/cman_tool nodes
Node  Sts   Inc   Joined               Name
   1   M      4   2007-03-27 18:37:24  pg-hba-001
   2   X      8                        pg-hba-002

Maybe this could be fixed in the upcoming errate too. By the way: can you tell 
me when this errata can be expected?

Kind regards,
Robert Hell

Comment 5 Kiersten (Kerri) Anderson 2007-04-23 17:46:43 UTC
Fixing Product Name.  Cluster Suite components were integrqated into Enterprise
Linux Version 5.0.

Comment 6 Jim Parsons 2007-09-12 20:40:51 UTC

*** This bug has been marked as a duplicate of 236014 ***


Note You need to log in before you can comment on or make changes to this bug.