Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233621 - It's not possible to manage a cluster with system-config-cluster (wrong path to cman_tool in CommandHandler.py)
Summary: It's not possible to manage a cluster with system-config-cluster (wrong path ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-cluster
Version: 5.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Jim Parsons
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-23 14:07 UTC by Robert Hell
Modified: 2009-04-16 22:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-03 17:08:48 UTC


Attachments (Terms of Use)

Description Robert Hell 2007-03-23 14:07:53 UTC
Description of problem:
After Configuring a Cluster with system-config-cluster on one node, this node 
is not recognized as member of the cluster when starting system-config-cluster.

So a running Cluster cannot be managed with system-config-cluster.
Error message: Because this node is not currently part of a cluster, the 
management tab for this application is not available.

Version-Release number of selected component (if applicable):
RHEL 5 AP: system-config-cluster-1.0.39-1.0

How reproducible:
Steps to Reproduce:
1. Installing cluster RPM's
2. Configuring cluster with system-config-cluster
3. deploying /etc/cluster/cluster.conf to all nodes manually
4. Starting cluster services
5. Starting system-config-cluster
6. Error Message: Because this node is not currently part of a cluster, the 
management tab for this application is not available

Actual results:
Because this node is not currently part of a cluster, the management tab for 
this application is not available

Expected results:
Managing the cluster with system-config-cluster

Additional info:
Reason: Wrong path to cman_tool in CommandHandler.py.
cman_tool is installed in /usr/sbin/cman_tool but is used in CommandHandler.py 
under /sbin/cman_tool.

After creating a link (ln -s /usr/sbin/cman_tool /sbin/cman_tool) everything 
works fine.

Comment 1 Jim Parsons 2007-03-23 15:47:11 UTC
There is an upcoming async errata for this issue - sorry for your pain.

Comment 2 Kiersten (Kerri) Anderson 2007-04-23 17:47:06 UTC
Fixing Product Name.  Cluster Suite components were integrqated into Enterprise
Linux Version 5.0.

Comment 3 Eli Stair 2007-08-28 02:22:11 UTC
Any follow up on this issue, when/where (date/update version & package) a fix is
going to be presented?  It doesn't seem to have been mentioned that this impacts
the new RHEL5 Conga web interface as well.

Thanks,

/eli

Comment 4 Jim Parsons 2008-10-03 17:08:48 UTC
This was fixed a few releases ago. It works in the current release


Note You need to log in before you can comment on or make changes to this bug.