Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2336 - cpio header info lost in versions prior to pl 11
Summary: cpio header info lost in versions prior to pl 11
Keywords:
Status: CLOSED DUPLICATE of bug 226
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cpio
Version: 5.2
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-23 13:28 UTC by Dan Yocum
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-04-23 15:15:45 UTC


Attachments (Terms of Use)

Description Dan Yocum 1999-04-23 13:28:52 UTC
Forwarded message follows from Chris Green.

Dan

******************

Hi,

Some extremely detailed work by Randy [Herber] in
determining why a Linux backup using cpio failed has found a
bug in the cpio package for any rpm below patchlevel 11
(which we have determined fixes the bug). The rpm which
comes with FRH521 [i.e., Red Hat 5.2] is at patchlevel 9,
which also has the bug.

Basically, if one uses

cpio -Hodc -o

(the most portable way to output information via cpio), then
the header information before each cpio item has the
namesize and filesize attributes missing -- effectively a
showstopper to having the backup read back in any usable
fashion.

<snip>

Thanks,
Chris.

--
Chris Green. HEP, Purdue University. CDF SVXII project.
Based at Fermilab. MAIL greenc@fnal.gov; PHONE (630)
840-2308

Comment 1 Jeff Johnson 1999-04-23 15:15:59 UTC
*** This bug has been marked as a duplicate of 226 ***


Note You need to log in before you can comment on or make changes to this bug.