Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 233590 - Error message "HAL does not support power management!"
Summary: Error message "HAL does not support power management!"
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-03-23 12:04 UTC by Joachim Frieben
Modified: 2013-03-06 03:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-31 15:52:24 UTC


Attachments (Terms of Use)
Warning about missing support of power management. (deleted)
2007-03-23 12:06 UTC, Joachim Frieben
no flags Details
hald crash output (deleted)
2007-03-26 02:20 UTC, Joe Ammond
no flags Details

Description Joachim Frieben 2007-03-23 12:04:47 UTC
Description of problem:
For current "rawhide", "hal" seems to be broken. "g-p-m" aborts on
start-up, and in "/var/log/messages", entries

 "gnome-power-manager: (fedora) Either HAL or DBUS are not working!"
 "gnome-power-manager: (fedora) HAL does not support power management!"

appear.

Version-Release number of selected component (if applicable):
hal-0.5.9-0.git20070304.fc7

How reproducible:
Always.

Steps to Reproduce:
1. Log in to "GNOME" session.
  
Actual results:
No "g-p-m" icon is present in the desktop panel. "g-p-m" aborts when
launched.

Expected results:
"g-p-m" is up and running.

Additional info:
None.

Comment 1 Joachim Frieben 2007-03-23 12:06:43 UTC
Created attachment 150745 [details]
Warning about missing support of power management.

Comment 2 Ronny Fischer 2007-03-25 09:52:51 UTC
I can see the same on Fedora 7 Rawhide 6.92 Kernel 2.6.20-1.3017, i686.

HAL starts on boot but it seems it is stopping right after that. It is possible 
to restart haldaemon, but it doesn't work correectly at all. This results in 
not being notified on different system events (e.g. mounting a CD).



Comment 3 Joe Ammond 2007-03-26 02:15:28 UTC
I've been having the same problem with hald. I finally started it manually with
--verbose=yes and --daemon=no, and captured attached log. One interesting line is:

process 16057: arguments to dbus_message_new_error() were incorrect, assertion
"_dbus_check_is_valid_error_name (error_name)" failed in file dbus-message.c
line 1207.
This is normally a bug in some application using the D-Bus library.
  D-Bus not built with -rdynamic so unable to print a backtrace

I see that when I exit evolution lately as well.

Comment 4 Joe Ammond 2007-03-26 02:20:17 UTC
Created attachment 150865 [details]
hald crash output

crash from hald.

Comment 5 David Zeuthen 2007-03-26 02:21:31 UTC
Should be fixed upstream already

http://gitweb.freedesktop.org/?p=hal.git;a=commitdiff;h=f038b39e6eddb393c6793b3932eb978346fa528b


Comment 6 Joe Ammond 2007-03-26 02:25:35 UTC
Great, I'll look for an update to rawhide in the future.

Comment 7 Will Woods 2007-03-27 22:57:00 UTC
Could you test with hal-0.5.9-0.git20070326.fc7? It should be in rawhide today.

Comment 8 Joachim Frieben 2007-03-31 15:52:24 UTC
Looks ok again. Thanks!


Note You need to log in before you can comment on or make changes to this bug.